Komodo IDE

Why does Komodo tell me that "Komodo does not Support execution of <enter language here>"? I know it does.

Question: 

Why is Komodo IDE telling me it does not support Python (for example) debugging when I know it does?

Answer: 

This usually means that your Komodo install isn't configured properly for the supported language.

Try checking the following to see if it helps:

  • View > Start Page > Check Configuration: Make sure there are green check marks on your language.
  • The file type (bottom of screen, language popup list).
  • Preferences > Languages > your language > "Use this interpreter": "Browse" to the interpreter you want to use.

There is a known issue with Windows and Cygwin that overrides anything in your path. If you have done the above, you have Cygwin isntalled and on your system path, and debugging is still not working, you can do the following:

  • Preferences > Environment > Double click "PATH" in the "Startup environment variables" section
  • Double click "PATH" in the bottom section now
  • Click the little double down arrows in the dialog that appears
  • Find any references to Cygwin and delete it from the PATH

This will remove Cygwin from Komodo's reference of the system path and has no effect on your computer's system path. Remember you did this though! It will block Komodo from seeing other system path changes you may want Komodo to detect later on.

Cheers,

- Carey

I'm stuck in Full Screen mode on OS X! Help!

Question: 

I entered full screen mode through the Komodo menu and now now I'm stuck. How do I get out?

Answer: 

If you are stuck in Komodos Full Screen mode and you can't seem to turn it off, we have a work around for you until the issue is resolved properly.

- Cmd + Q to exit Komodo
- open the following file in a text editing program: /Users/*username*/Library/Application Support/KomodoIDE/8.0/prefs.xml
- search the "startupFullScreen" preference and change the 1 to 0
- DELETE the prefs.xmlc file (it's a back and will over write the change you just made)
- start Komodo

Once you've accomplished this you can assign a keybinding to full screen mode through Preferences > Editor > Key bindings: Search "full screen" and assign whichever key binding you like to it.

This will not be an issue for long.

- Carey

Komodo IDE and Right-to-Left (RTL) Languages

Question: 

Will Komodo work with Farsi, Hebrew or some Asian languages that are read right to left?

Answer: 

Komodo unfortunately does not work with right-to-left languages, as mentioned in our Komodo IDE release notes, due to a limitation in the text editor component.