OS X 10.8 (Mountain Lion)

Mac OS X 10.8 (Mountain Lion)

Can't run a compiled Tk Mac OS X application


I made executable with ActivePerl 1604 and Perl Dev Kit 9.

But it won't run on some OS X systems. I got the following error message:

Can't load 'auto/Tk/Tk.bundle' for module Tk: dlopen(auto/Tk/Tk.bundle, 1): image not found at /</Users/K/Desktop/hoge/hoge_exe>DynaLoader.pm line 223, <DATA> line 855.
 at perlapp line 827.
BEGIN failed--compilation aborted at hoge_exe.pl line 105, <DATA> line 855.
MacBook-Air:hoge K$

It runs fine on some systems, but I get the above error on some systems.

Any ideas?

Why ActivePerl-5.18 is not a universal binary?


I downloaded and installed ActivePerl- DMG on my Mac OS X Mountain Lion and I observed that the perl binary is not actually universal.

$ file /usr/local/ActivePerl-5.18/bin/perl
/usr/local/ActivePerl-5.18/bin/perl: Mach-O 64-bit executable x86_64

whereas the earlier version was universal:
$ file /usr/local/ActivePerl-5.14/bin/perl
/usr/local/ActivePerl-5.14/bin/perl: Mach-O universal binary with 2 architectures
/usr/local/ActivePerl-5.14/bin/perl (for architecture i386): Mach-O executable i386

Cannot install scipy

I am trying to install scipy and it fails with the following message:

:~ pypm install scipy
warning: no such package found for requirement "scipy"; try PyPM Index:

the web page shows scipy available for python 3
I am trying this install with the python 3.3 on OSX 10.8. I tried the same with OSX 10.9

What am I doing wrong?

Building 64bit executable using PDK

I would like to create a 64-bit executable (x86_64) on Mac OS using PDK as opposed to a Universal executable (x386/x86_64) in order to reduce the size of my application. However, perlapp issues error messages: error : Mismatch between perlapp (i386/x86_64) and xxx (x86_64). Producing a Universal Binary is not possible

Is it possible to use PDK for building a 64-bit executable? Please advise...

What permissions are necessary for PPM to allow access to area: perl?

I'm an admin on my Mac (running OS X 10.8.2) and have installed ActivePerl-5.14. My PPM does not allow me access to the install area: perl. I'm assuming there's a permissions issue. Can someone please let me know what perms are required to install in this area?

Mac OX 10.8.2 - ActivePerl 5.16.1 - PPM crashes on open


I have a clean install of OSX 10.8, with the latest updates to 10.8.2. I just installed ActivePerl 5.16.1 and tried to start PPM to configure my repositories and to add a couple packages that I need.

The PPM gui appears and I can see the statement that databases are being synchronized, then PPM crashes.

Is the latest ActivePerl version compatible with my OS version? Any suggestions I can try?

Here is the Problem Report:

Process: perl-dynamic [768]
Path: /usr/local/ActivePerl-5.16/bin/PPM.app/Contents/MacOS/PPM
Identifier: com.activestate.PPM

how to make old scripts using snack work?

I'm coming back to tcl and in particular the snack library after a multi-year hiatus. I'm a scientist who occasionally must program, not a programmer. I'm trying to get old scripts I'd written to work. Here's an example of a script that used to work:

# the next line restarts using wish \
exec wish "$0" -- "$@"
# /usr/bin/wish

package require snack

foreach sndfile $argv {
sound snd -load $sndfile
set infos [snd info]
set srate [lindex $infos 1]
set slength [snd length]
set msecs [expr ($slength * 1000.0 / $srate)]

Tcldebugger doesn't play well with TclOO ?


I'm trying to use tcldebugger with TclOO, but each time a use a step button (say "Step Over"), tcldebugger call stack shows what I suspect is an internal TclOO proc, with an empty source window ("No source code..."). If I manually select the good frame in the call stack, I get my code back with appropriate variables... Here are a few screenshots with a very simple code to illustrate this :

After "Step Over" :

After clicking on the "good" frame to go back in code :

PPM and PerlCritic GUIs crash after upgrading to ActivePerl-5.16 on Mac OS X 10.8.1

Command line works fine for both. ActivePerl-5.14 worked fine. Re-installed lastest ActiveTCL

Perl Critic fails as follows (PPM crash output will follow below):

Process: perl-dynamic [2981]
Path: /usr/local/ActivePerl-5.16/bin/PerlCritic.app/Contents/MacOS/PerlCritic
Identifier: com.activestate.perlcritic
Version: 10.00 (10.00)
Code Type: X86-64 (Native)
Parent Process: launchd [490]
User ID: 501

Date/Time: 2012-09-12 15:12:39.605 -0400
OS Version: Mac OS X 10.8.1 (12B19)
Report Version: 10

uninstall script for activetcl does not work

I am trying to uninstall activetcl using the uninstall script. However, the uninstall will fail and report:

Reason: ErrorMissingBundle


uninstall file_urls ...
child process exited abnormally

How can I get the script to work properly?

Thank you for any help!


OS X 10.8 Mountain Lion