PyPM (discontinued)

PyPM has been discontinued. Please use "pip install" or "python -m pip install" instead

pypm' is not recognized as an internal or external command

pypm' is not recognized as an internal or external command

The program was loaded
And reboot the computer
But the file did not appear

How can I solve the problem?

pypm Package installer

I've installed both the 32 and 64 bit community version 3.5 of Active Python and cannot get the Package installer Pmpy to run. I cannot locate the file pypm anywhere on my system.

Is pypm a separate download?

Humbly,

Bitdog

Get a Newer Version of a Package then is in PYPM

Hi, I need Django 1.9 I did:

C:\Windows\system32>pypm  show django
Name: django
Latest version: 1.8
Author: Django Software Foundation 
Summary: A high-level Python Web framework that encourages rapid development and
 clean, pragmatic design.
Home Page: http://www.djangoproject.com/
License: BSD
Available versions: 1.8, 1.8a1, 1.7.7, 1.7.6, 1.7.5, 1.7.4, 1.7.3, 1.7.2, 1.7, 1
.6.7
Status: Not installed

But I need version 1.9. Is the a way I can get 1.9 via pypm or is it possible to use a tool like pip? Thanks for your help.

cannot establish a ssh connection using paramiko

Hi,

I am trying a simple python program using paramiko. The program is as given below.

import paramiko
ssh = paramiko.SSHClient()
ssh.connect(' 10.126.74.198', username='test', password='test')

When I execute this program ,I am getting the error as given below.

C:\Python27>python.exe ssh.py
Traceback (most recent call last):
File "ssh.py", line 3, in
ssh.connect(' 10.126.74.198', username='test', password='test')
File "C:\Users\esujsom\AppData\Roaming\Python\Python27\site-packages\paramiko\
client.py", line 237, in connect

pycrypto, ActivePython 3.4.1.0 64 bit no module 'winrandom'

g'day,
Just a quicky - I'm trying to get paramiko running to do some ssh login stuff, and I used pypm to install it :

pypm install paramiko

All seemed to go well.
Then I tried to import it :

ActivePython 3.4.1.0 (ActiveState Software Inc.) based on
Python 3.4.1 (default, Aug 7 2014, 13:09:27) [MSC v.1600 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import paramiko
Traceback (most recent call last):
File "", line 1, in

Error installing pymssql using pypm

I am getting a failure trying to install pymssql using pypm, Python 2.7 x86 on Windows Server 2012, 2008, Windows 8 and Windows 7.

First attempt:

PS C:\> pypm -g install pymssql
Get: [pypm-be.activestate.com] :repository-index:
Get: [pypm-free.activestate.com] :repository-index:
autosync: synced 2 repositories
The following packages will be installed into "c:\Python27" (2.7):
pymssql-2.1.0
Get: [pypm-free.activestate.com] pymssql 2.1.0
error: Can't install pymssql-2.1.0: HTTP Error 404: Not Found

***

(Some downloads occur)

Subsequent calls fail immediately:

Error installing cx-oracle using pypm

I'm getting an error installing cx_oracle using pypm for Python 2.7.8.10

Where do I find makepy.py?

Where could I find makepy.py?

Cannot install Pycrypto on Python 2.7

I have installed both ActivePython-2.7.8.10-win64-x64.msi and ActivePython-2.7.8.10-win32-x86.msi and attempting to install Pycrypto I get the error "Python version 2.6 is required, which was not found in the registry."

Cannot install scipy

I am trying to install scipy and it fails with the following message:

:~ pypm install scipy
warning: no such package found for requirement "scipy"; try PyPM Index:
http://code.activestate.com/pypm/search:scipy/

the web page shows scipy available for python 3
I am trying this install with the python 3.3 on OSX 10.8. I tried the same with OSX 10.9

What am I doing wrong?