tbcload

TDK 4.0.2 needs Tcl 8.5?

Question: 

I've installed TclDevKit 4.0.2 and ActiveTcl 8.4.16 to compile my Tcl scripts. The problem is that the .tbc files generated by the Tcl Compiler
are only usable with tbcload 1.7 and only for Tcl 8.5. The message in the installation dialog suggests to take the packages from an Tcl 8.4 distribution.

Answer: 

TDK 4.0 comes with support for both 8.4 and 8.5. The unversioned tclcompiler executable is for 8.5, and tclcompiler84 is for 8.4. If you are using TclApp and the checkbox for this, there is a version specifier combobox right next to it for your convenience. In addition, it will auto-detect the version of the basekit you are using.