compatibility

Tk compatibility problem with PPM module

Question: 

I have installed the module Tk-TableMatrix 1.23 ( Installed from AS, using
AS Perl Package Manager). All my scripts using this module are broken. I
have tried to run the "demo" scripts provided in the package. And no matter
which one I run. I get the following message.
--> perl -w basic.pl

Tk::TcldeclsVtab wrong size for TcldeclsVtab at
C:/PRG/Perl/lib/DynaLoader.pm line 252.

Tk::TkeventVtab wrong size for TkeventVtab at C:/PRG/Perl/lib/DynaLoader.pm
line 252.

Answer: 

You need a version of Tk-TableMatrix 1.23 that is compiled against Tk 804.x.

When the Tk shipped with ActivePerl was updated to 804.x in the middle of the 5.8.x series, it was recognized that modules which depended on Tk would need to be recompiled. Doing so would, however, makes those modules incompatible with older releases still using Tk 802.x. Since PPM only supports one version of any given module revision per repository, all those older 5.8.x releases would have lost their PPM sources.

Improvements to the functionality of PPM are envisioned which will allow dependency based selection of module versions. For now, the workaround has been to distribute different versions of these modules with compatibility issues from different PPM repositories, some of which are not maintained by ActiveState.

Modules with dependencies on Tk802.x will continue to be available at ActiveState. Modules with dependencies on Tk804.x are available from Randy Kobes' University of Winnipeg PPM repositories:
http://theory.uwinnipeg.ca/ppmpackages/

What is the best version of ActivePerl to use with Windows 7?

Question: 

What is the best version of ActivePerl to use with Windows 7?

Answer: 

The best version of ActivePerl to use on Windows 7 is always the most recent build of ActivePerl.

ActivePerl passes the same suite of tests on Windows 7 as they do on Windows XP or Vista and other supported versions of Windows.

ActivePerl's known issues on Windows Vista include:

  • PerlIS and PerlEx are installed but not automatically configured due to differences in the script extension mapping process for IIS
  • the OLE browser will not function with Internet Explorer 7

If you run into other issues, please report them at:

http://bugs.activestate.com

What version of Komodo should I use with Windows Vista?

Question: 

What version of Komodo should I use with Windows Vista?

Answer: 

Komodo 3.5 and earlier will not work with Vista. You will need to run Komodo 4.1.1 or later.

Should you run into any issues, please file a bug report at:

http://bugs.activestate.com/