Windows Server 2003

ppm install yields an error...

When attempting to add packages to Perl, which I installed for an instance Bugzilla,

Downloading DBD-mysql-4.029...failed 500 write failed: Bad file descriptor
ppm install failed: 500 write failed: Bad file descriptor

I cannot find any other posts about this. Any idea to fix it?

John

OS: Windows Server 2008 R2 using IIS

Perl Package Install error

C:\Documents and Settings\ccadm>ppm install Crypt::SSLeay
Error: No valid repositories: Error: 404 Not Found at C:/Program
Files/Perl/site/lib/PPM/Repository.pm line 84

It's because the space in the directory - Program Files.

How to fix this?

PPM 3.4 / DBI Installation issue

We are using Perl 5.8.8 and need to install the DBI communication package (Oracle 11G Enterprise DB). When I launch PPM and issue the Install DBI command I get " Error: No valid repositories: Error: 404 Not Found"

PPM - Programmer's Package Manager version 3.4.
Copyright (c) 2001 ActiveState Software Inc. All Rights Reserved.

Entering interactive shell. Using Term::ReadLine::Perl as readline library.

Type 'help' to get started.

ppm> Install DBI
Error: No valid repositories: Error: 404 Not Found

Firewall issue?

perlis.ddl missing?

I just upgraded to Perl 5.16.3 (on Win 2003) due to an "ActivePerl Heartbleed Security Update" email from activestate. After the upgrade my plx scripts stopped working on my web site. I checked IIS and it was set correctly to map plx to c:\perl\bin\perlis.dll.
I checked and perlis.dll did not exist! I ran the installer again and checked PERL ISAPI and I got: "Use of this feature requires a Business Edition license". WTF!? When did this start? Can anyone help me with this?

how do uninstall a ActivePerl license from the wrong machine?

this question has been resolved via a support ticket.

Upgrading from 5.8.822 to 5.16.x

Hello all,

I work for a company which is currently using AP 5.8.822 on their 2003 box and have quite a few Perl scripts. I see in the AS 5.16 documentation, it says build 16xx is incompatible with previous version's binaries, though I'm not sure what that entails.

If we were to upgrade to 5.16.x as I have on my PC, would it break all of the existing Perl scripts written and used in the 5.8.822 environment? I would like to upgrade so I can use the remove_tree function and output to a scalar variable for logging purposes, as opposed to just the spray and pray of rmtree.

Can't access the internet using ActivePerl 5.18.1.1800

Not sure how this makes any sense but I've got a brand new windows 2008 server and I installed 5.18.1.1800 (latest community edition) and I go to do some updates but nothing can access the internet with it. PPM can't find anything, CPAN can't find anything, there's no proxy configured or need for there to be any, its a direct connection to the internet. I went ahead and tried to use a proxy, that had no effect and still didn't work.

Can not installl DBD-OBDBC modul2

trying to rebuild the environment on a clean machine. Apparently we have corrupted or mismatching DBD-ODBC.PDD files. Error: no suitable installation target found for package DBD-ODBC. DBI installes ok, dbdb-ORACL also. Just can't that last module installed. Active perl version is 5.8.4.810. Not sure I have correct PPD or Gz files. trying to install off local disk.

Unable to install MIME-tools on system ‘Winserver 2003 R2 standard x64 SP2’ where perl version is ’ v5.8.8'

Hi

My system is ‘Windos server 2003 R2 standard x64 edition SP2’ and perl version is ’ v5.8.8 built for MSWin32-x86-multi-thread’.

perl -v

This is perl, v5.8.8 built for MSWin32-x86-multi-thread(with 25 registered patches, see perl -V for more detail)

Copyright 1987-2006, Larry Wall

Binary build 817 [257965] provided by ActiveState http://www.ActiveState.com Built Mar 20 2006 17:54:25

Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit.

Local repository didn't work, remote repository did ?

Hi all,

Could anyone explain the reasons behind what I had to do here ?

I know nothing about perl/tk, but I had to install a (Win Server 2003) application which needed Active Perl 5.12.x and Perl Tk, and they had to be installed manually. The application assumes internet access is available to get the Tk module, but it wasn't in this case.