Windows 7

ActiveTcl Windows Installation not allowing "all users" install

Windows 7 Install of ActiveTicl 64-bit not allowing all users
komodingo | Fri, 2012-11-16 05:08
I am installing the lastest Windows version of ActiveTcl 64-bit. I get to a dialog box that asks me to "Please specify installation directory and mode.

Installation mode

( ) Install for current user only

( ) Install for all users (requires Administrative privileges)

I have admin privileges for my user ID so I don't understand why it isn't allowing the 2nd option to be selected.

No Output When Running Perl Scripts

I have used Active State Perl for a few years on other machines (XP, Vista), but am unable to get Perl to install correctly on my new Windows 7 64 bit machine. When I run a Perl script that outputs to the screen, I see no output. The output screen is blank (no errors appear).

Embarrassingly even a simple "Hello" program won't run.

I'd appreciate any help.

thanks,
Wyatt

Unable to run perl on windows 7 64-bit machine (DBD::Oracle error)

Hi,

I tried to run a perl program on windows 7 64-bit machine which is compiled and generated with PDK 8.2.1 32-bit build. It is throwing error as below

"install_driver(Oracle) failed: Can't load 'C:/Perl/lib/auto/DBD/Oracle/Oracle.dl
l' for module DBD::Oracle: load_file:%1 is not a valid Win32 application at C:/P
erl/lib/DynaLoader.pm line 201.
at (eval 6) line 3
Compilation failed in require at (eval 6) line 3.
Perhaps a required shared library or dll isn't installed where expected
at twconnectsql.perl line 2229"

Missing documentation

Hi.

I have installed Activeperl 5.16.1 on two PCs. Both run Windows 7 but one is 32bit and the other 64bit. I have installed the correct version of Activeperl on each.

However, the 64bit version is mission a lot of documentation, including the core documentation. The 32bit version seems fine.

This is a nuisence, as I do not always have an internet connection.

Make work around is to copy the 32bit documentation, but it would be nice if the install provided all the documentation.

Stephen.

Simple recipe to break PPM in ActivePerl 5.16

I'd recently installed ActivePerl 5.16 onto my development box. As a Komodo user who likes the built in perlcritic feature, I immediately opened up PPM to install 'criticism'. Not available. =/

OK, I can work around this:
Install App-cpanminus.
Use cpanm to install criticism.

Upon relaunching ppm, I discovered that it was now using the module versions in the 'perl' section instead of the 'site' section to determine which modules needed updating and the 'settings' dialog was no longer able to be brought up.

wxmsw28u_core_VC_custom.dll is missing

Hi All,

I am getting an error for the perl scripts using Wx into my program.
Here is the error it is being thrown in the console :
wxmsw28u_core_VC_custom.dll is missing.

Could not able to find out how to rectify this? Please help.

Thanks,
pullabhotlas

is community edition free?

I need Perl to connect to Oracle & extract data in text format.
Would appreciate if you can let me know whether the Perl Community Edition will help. Got to know this is a free version and won't need a liscense. Is that true /

TIA
Raj Nair

HTML Users Guide not updated with PPM modules, and missing sections

I recently added a new package with PPM, and was looking for the documention. New packages downloaded with the PPM should show up in the ActiveState User Guide, on the left pane contents, but there just seems to be a lot missing, including the new package (Hash::Case). I have only 6 of the 300 packages installed, nothing under Core, 1 pragma, 2 programs.
Can I fix this and get the documentation to the installed packages and core?

As a workaround, can I find the HTML PPM said it was generating somewhere? I've looked at C:/Perl/lib/site but it's not there with the pm.

Canno't setup GTK2 module

Hello every body

I am using Perl ActiveSate under Win7. So, I would like setup GTK2 module with ppm gui.

But I haven't this module in the lits of all modules.

Do you have some idea. What is the best repository to downlaod this Perl Module

Thank in advance

using ppm through a proxy

Hello,
I am just getting started with activeperl 5.14 on my windows 7 64-bit system.

I am connected tothe internet through a proxy, and I am wondering how I tell ppm to use the proxy to access the repositories?
Where do I tell ppm to use the proxy?