Windows 7

PPM crashes after fresh install of Perl 5.16.3

On my Win 7/64-bit system, I did a clean uninstall of AS 5.16.1/64-bit, then a clean install of AS 5.16.3/64-bit.

When I then tried to run PPM, it immediately crashed.

I uninstalled, rebooted and reinstalled, same crash.

I uninstalled, deleted C:\Perl64 directory and then reinstalled, same crash.

I'm going to try 5.16.2 now. Any other suggestions?

Rick

installation url-package

hi !

i want to install the url-lib (https://metacpan.org/pod/URI) - but in the package-assistent this i did not found.

can someone help me for win7 64 bit ?

regards Jan :-)

PPM downloads for Community Edition?

I have the free Community version of Active Perl (Version 5.16) installed on my PC. I am trying to use CPAN to install the Path-Class package, but I can no longer connect to the ppm4.activestate.com:80 server when PPM attempts to download the package. Are all CPAN packages now banned from the shareware community? I have successfully used PPM to install MooseX and other packages from your server in the past. What has changed?

ActivePerl 5.16.3. - Perl Module Installation via PPM: Extraction error with the .tgz

Hi there,

I have ActivePerl 5.16.3 running on a Windows 7 64 bit. I'm attempting to install the Perl module DBIx-JSON by launching the PPM, marking the said module for install and then running marked actions via the UI.

I'm getting the error below when I do this:

ERROR: Can't extract files from C:\Users\mycorporateuserID\AppData\Local\Temp\ppm-Jw5UXe/DBIx-JSON-0.02.tgz

PPM packages for IUP on Windows

I would like to have a ppm for IUP, a perl module providing a graphical user interface.
IUP: http://search.cpan.org/~kmx/IUP-0.101/lib/IUP.pod

I tried to build it within Strawberry perl (portable, version 5.18.1, on Windows 32 bit) and it worked flawlessly through cpanm:
cpanm --prompt IUP
No problem even on some Linux machines.

As I see, your automatic attempt to build the ppm fails because of a timeout, but without any real issue: http://code.activestate.com/ppm/IUP

Regards,
Ugo

AP 2.7 does not install debug libs?

i'm building an app that embeds python

the debug build won't even link because "python27_d.lib" does not exist.

why not and/or where can i get it / how can i create it?

No portable version available?

I would like to use ActivePerl occasionally from USB Stick but don't want to install it permanently on a computer.

Is there no "portable" version available for download?

peter

Installing ActivePerl (64) under "Program Files" disallows updation

I installed ActivePerl under "C:\Program Files\" and when I run PPM it just doesn't update the repository, says there's a permission problem?

I installed it as the System user and have done everything to give Perl64 under "Program Files" read+write permissions, no use.

On the other hand, installing Perl64 directly under "C:\" doesn't have any of the above mentioned problems, just that it's better to maintain a proper hierarchy, hence installation under "C:\Program Files\".

Can someone help?

Problem running a Python Program and PyPM install packages

I'm running: Window 7 Enterprise

Download: ActivePython-3.2.2.3-win32-x86.msi
* ActivePython Documenation
* IDLE (Python GUI)
* Python Interactiveve Shell
* Python Package Manager (PyPM)

It went to directory:
C:\Python32

I save the following Python Program:
test.py
#! /usr/bin/env python3.2
primes=[2,3,5,7]
for i in primes:
print(i)

I tried to run my Python Program
F:\ > test.py
Choose the program you want to use to open this file: C:\python32.exe
And nothing happen, it did not run.

Could this be the problem and how can I correct it?

Upgraded to PERL 5.16 and can get module Log-StdLog: Windows 32bit

I upgraded to 5.16 and now I can't get Log-StdLog: Windows 32bit.
http://code.activestate.com/ppm/Log-StdLog/

Is there something else I can use or should I go back to earlier revision of PERL??