Windows 7

Wondering if ppm GUI defaults to --nodeps

Hi,

I'm using ActivePerl v5.8.9 built for MSWin32-x86-multi-thread. I am only using one ppm repo, the default ActiveState one for this build:

http://ppm4.activestate.com/MSWin32-x86/5.8/827/package.xml

I am trying to write a batch script that will install all required modules to run Catalyst. If I use ppm at the command line to install Catalyst-Runtime, for example, I get a dependency error:

ppm instal Catalyst-Runtime
ppm install failed: Can't find any package that provides namespace::clean version 0.13 for Catalyst-Runtime

5.10 x64 repo not found

I am trying to install modules on activestate perl 5.10 build 1007 x64 and cannot get the repository to download. Any ideas why?

I get the following error when syncing through ppm:

Downloading ActiveState Package Repository packlist ... not found

I am trying to connect to http://ppm4.activestate.com/MSWin32-x64/5.10/1007/package.xml.

I would rather not have to manually compile all of the modules that I need to install for my project from cpan. Your help is much appreciated.

Thanks,
Troy