Windows 7

ActiveTcl installer hangs on Windows 7

When I run the ActiveTcl installer on my Windows 7 box, the installer window has no contents, the console window says downloading 1% and then it never changes after that point. I would appreciate any tips/help.



how to unzip/extract the zip file and again zip it using Perl?

how to unzip/extract the zip file and again zip it using Perl?

showing error messages

I have a perlapp exe that runs fine on the development computer. On another computer it does not load and briefly flashes a console window with an error message. There is no way to read the message. How can I pause the message so I can read it? The exe is a TK graphical program. The error occurs before the TK GUI is posted.

Cannot Install ActivePerl 5.10.1 Build 100[457]

When I try to install ActivePerl 5.10.1 Builds 1004, 1005, or 1007, I get the following message box:

Installer Information
The system cannot open the device or file specified.
[Retry] [Cancel]

If I click [Retry], the same message box appears. If I click [Cancel], I get:

Installer Information
Internal Error 2755. 110,

Clicking [OK] displays the setup wizard with a message that says that the "Setup Wizard ended prematurely"

I'm running 32-bit Windows 7 Enterprise.

UltraNoob "ppm install Tk-804.028.ppmx" failed: can't call method "get_files"...

Disclaimer: I am (definitely) not a programmer.

Following a Snort install guide for Windows 7 (on 64bit)

perl -v gives:
v5.10.1 for MSwin32-x64-multi...

i had to twiddle my path variables and added
c:\perl64\bin and c:\perl64\site\bin

when i run "ppm" alone from an administrator cmd, it pulls up a gui window and seems to connect and download/update ok.

however, when i try to run a specific command to install a particular file, i get the following:

>ppm install Tk-804.028.ppmx

.pl file associations for multiple users in Windows 7

I recently signed onto a Windows 7 computer and installed the 32 bit ActionPerl msi on our domain. Now when I sign in and goto the commnad prompt, I can run .pl files without the full path and it knows to associate the .pl file with the perl executable. However when one of our other users logs in, he is unable to run the perl scripts without using the full path and the preceding perl call. It seems that the file associations for pl worked fine for myself, but I need these to be associated for a few other users. I wanted to know how I can go about doing this.

Tk build issue on Windows 7

I just upgraded to Win 7 x64 & am trying to build Tk-804.028 using Microsoft Visual Studio 9.0, I have tried setting up the enviornment using vsvars32.bat, but Tk::X fails with:
X.obj : fatal error LNK1112: module machine type 'X86' conflicts with target machine type 'x64'

while seting the enviornment with vcvarsx86_ia64.bat results in:
X.obj : fatal error LNK1112: module machine type 'IA64' conflicts with target machine type 'x64'

Any suggestions would be appreicated...

printing in word 2007 fails

I'm trying to print every second page from all word documents in the current working directory.

When I excecute my script $! gives me the error "No such file or directory".

I've got the values for the PrintOut method by excecuting a macro in microsoft Word.

Has anyone any ideas?

tnx! Bram

use Win32::OLE;
use Win32::OLE::Const 'Microsoft Word';
use Cwd;
use File::Find;

my $Word = Win32::OLE->new('Word.Application', 'Quit');
#print $Word;
my $dir = getcwd;
#print $dir;

push @directories, $dir;

find(\&wanted, $dir);

Tcl wasn't installed properly on Windows 7

I recently installed ActiveTCL on a Windows 7 host. However, I have the following problems:

  1. Starting Tclsh85 produces the following errors:

    application-specific initialization failed: Can't find a usable init.tcl in the following directorie
    {C:\Tcl\lib\tcl8.4} C:/Tcl/lib/tcl8.5 C:/Tcl/lib/tcl8.5 C:/Tcl/lib/tcl8.5 C:/lib/tcl8.5 C:/Tcl/library C:/library C:/tcl8.5.8/library C:/tcl8.5.8/library

    This probably means that Tcl wasn't installed properly.

Advanced workaround for PDK 8.2.1 on Windows 7


My PDK Start menu items and file associations don't work on Windows 7. The Release Notes just say to use the command line. Isn't there a better alternative to get these working?


Let's start with PerlApp, since that's the most widely used application.

To fix your Start menu icon, go to Start|All Programs|ActiveState Perl Dev Kit 8.2.1 Build 292072. Right click on PerlApp and select Properties. Go to the Target box and change the text from "...\bin\perlapp-gui.exe" to "...\bin\perlapp.exe" (in other words, just delete -gui from the entry). Select OK. The PerlApp Start menu icon will now work.

To fix your .perlapp file association you will need a command line with Administrator priviledge. This can be done by navigating to Start|All Programs|Accessories and right clicking Command Prompt. Select Run as Administrator. If your PDK is installed on the default path, enter the following command:
C:\> ftype perlappfile="C:\Program Files\ActiveState Perl Dev Kit 8.2.1\bin\perlapp.exe" --interactive "%1"
If you installed PDK on a different path, adjust the command above to match your installation. Your perlapp associations are now corrected.

If they are present in your version of PDK, the Start Menu icons for PerlCtrl, PerlNET, PerlSvc, and PerlTray can all be corrected as you have just done for PerlApp by deleting "-gui" from the Target box. (64-bit PDK versions will not have a Start Menu icon for PerlNET.)

Again, your version of PDK may not have all of the following tools. Repair the ones you have and use. If you installed on a different path, modify the command to match your installation.
Fix the association for .perlctrl by:
C:\> ftype perlctrlfile="C:\Program Files\ActiveState Perl Dev Kit 8.2.1\bin\perlctrl.exe" --interactive "%1"

Fix the association for .perlnet by:
C:\> ftype perlnetfile="C:\Program Files\ActiveState Perl Dev Kit 8.2.1\bin\plc.exe" --interactive "%1"
(PerlNet is only available in 32-bit versions of the PDK)

Fix the association for .perlsvc by:
C:\> ftype perlsvcfile="C:\Program Files\ActiveState Perl Dev Kit 8.2.1\bin\perlsvc.exe" --interactive "%1"

Fix the association for .perltray by:
C:\> ftype perltrayfile="C:\Program Files\ActiveState Perl Dev Kit 8.2.1\bin\perltray.exe" --interactive "%1"