Windows 7

PyPM in Windows 7 x64 - "Community edition"?

Hi all!

I'm a long time user of ActivePython (and paid Komodo user), and I've recently upgraded my OS from XP to Windows 7 - 64 bits.

As always when upgrading OS, one of the first things I do is install the "latest and greatest" ActivePython. Finding modules for 64 bits, I got the 64 bits build... but then I've discovered that PyPM is useless in the 64 bits Community Edition!!

I can (somewhat) understand not including PyPM in a "free" version - but if that's the case, then don't include it in the build!

Issues with Django South in PyPM

I installed both Django and South (a Django migration tool) with PyPM; however, upon using, the file wasn't picking up South's schemamigration or migrate commands. I ended up having to uninstall both Django and South with PyPM and instead use PIP to install those packages. After doing so, everything worked as it should.

Maybe there's a pathing conflict somewhere?

Excel WIN32::OLE Pivot table->chart Title

Hi @ all,

in recent days I try to talk about Perl with Excel 2007 (about WIN32::OLE).
I want to create a Pivot table + chart. But I couldn't create a chart Title. Please help me....

For a better understanding my perl code:

#! perl -w

use warnings;
use strict;

use Win32::OLE ;

my $excel = Win32::OLE->new('Excel.Application');
$excel->{'Visible'} = 1;

my $workbook = $excel -> Workbooks -> Add;

my $sheet = $workbook->Sheets("Tabelle1");
$sheet -> Range('A1')->{'Value'} = "Temp [°C]";
$sheet -> Range('B1')->{'Value'} = "Vcc [V]";

using syscall() function on windows 7

Hi, I installed ActivePerl on Windows 7 and I want to run the script as follows:

How can I measure time under a second?

In general, you may not be able to. The Time::HiRes module (available from CPAN) provides this functionality for some systems.

If your system supports both the syscall() function in Perl as well as a system call like gettimeofday(2), then you may be able to do something like this:

require 'sys/';
$done = $start = pack($TIMEVAL_T, ());
syscall( &SYS_gettimeofday, $start, 0) != -1

Problem building exe files with perlapp

Hi all,
I'm watching very often the following error during execution of perlapp:

Can't reopen 'xxxx.exe' for write: Permission denied at /Win32/ line 413.

When I start the same command a second time it is working in most cases.
After the error the resulting exe has the icon of perlapp and a start of the exe file results in a message that pdklib.dll is missing.


I am porting a Perl script to Windows 7. All works well except for
my $socket = Gtk2::Socket->new();
error message...
Can't locate object method "new" via package "Gtk2::Socket" ....

I am using the ppm package Gtk2 1.222. I can't seem to find anything about this on the web.

I want to attach the output window of Gnuplot to a VBox widget. Under Linux and on the MAC OS I can use

my $xxid = socket->get_id;

and pass it to Gnuplot as a hexadecimal string so that it exports its display to the Gtk2 VBox panel in my program.


'ppm repo sync' fails silently.

Hi all,

I'm trying to sync ppm with ActiveState repository on a fresh install of ActivePerl.

> ppm repo sync
Downloading ActiveState Package Repository packlist...done

> ppm log
2011-02-12T02:05:04 <6> [ppm:81] ppm repo sync
2011-02-12T02:05:04 <4> [] Setting up schema for C:\Users\Bahman\Ap
2011-02-12T02:05:43 <6> [] GET
/5.12/1203/package.xml ==> 200 OK (1225868 bytes in 38 sec - 32 KB/s)

Communicating with a modem

I am a newbie with Perl, running ActivePerl 5.12.2.

I want to communicate with a modem on COM3 and have written:

open (PORT,"+>COM3" ) or die "can't open COM3: $!";
print PORT "AT+CGMI\r";
$count = read(PORT, $buf, 83);

print STDOUT $buf;

close (PORT);

It just hangs and if I ^C out get:

Terminating on signal SIGINT(2)

I can access the modem without problem with ptty.

Can anyone help?

lsearch -index fails on windows 7 NOT

My error. The failing tcl/tk is the cgywin version. I did not realize that this was there and that the PATH was picking it first.

Please ignore this...

The lsearch command fails with an illegal option -index on my windows 7 system. This same command works correctly on windows XP. Versions I have tried: (on windows 7 and XP) -32 bit (windows 7 only) -64 bit (windows 7 only)

I used the same download of on both the XP and the windows 7 machine with the XP working and the windows 7 failing.

Install was as admin.

Any help here?

How to compile a program which uses %INC

I created and compiled the following test script with PerlApp. It extracts the directory pathname of the "Win32/" module file and opens the file under the same directory. The script works fine, but its executable fails with "Invalid argument" error because the module file can not be found.

How can I use PerlApp to compile a program which uses the %INC hash to access other module files? Did I do anything wrong? Do I need any options for PerlApp to make the executable work correctly?

use strict;
use Win32::Event;