Windows 7

Enhancement Request: PerlApp support for setting program compatibility

I would like to include setting the "Program Compatibility" of my created .exe file somehow in the PerlApp script. Or perhaps find out how to set the "Program Compatibility" in general for a .exe (that would work too!).

Windows 7 not seeing Expect

I am trying to install and run expect on a Windows 7 machine. I installed the 32 bit x86 version of Active Tcl, and I see expect installed, and I've updated with teacup. My Path seems to be okay, but tclsh is still not runing expect...

What am I missing?

Thanks

Daniel

% expect
invalid command name "expect"
%
%
%

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd /tcl/bin

C:\Tcl\bin>

C:\Tcl\bin>teacup install Expect

How to get started with GTK and QT

I need to write "hello world" in GTK and QT with perl on Windows 7 and FreeBSD 8.2.

I'm using ActiveState Perl on Windows 7 and it is not clear to me what packages I need.

I'm trying to follow the directions at http://gtk2-perl.sourceforge.net/ and I cannot find GTK2 in activestate PPM.

I'm also trying to get a QT version of "hello world" working and I cannot find the QT runtime for perl in PPM either. Can someone guide me and tell me what packages I need from active state perl from PPM?

Added later:

Where did Firefly go?

I leave work for an extended break and when I come back I cannot find FireFly. Did it go away and if so, can I get a backup copy of all my code?

PyPM in Windows 7 x64 - "Community edition"?

Hi all!

I'm a long time user of ActivePython (and paid Komodo user), and I've recently upgraded my OS from XP to Windows 7 - 64 bits.

As always when upgrading OS, one of the first things I do is install the "latest and greatest" ActivePython. Finding modules for 64 bits, I got the 64 bits build... but then I've discovered that PyPM is useless in the 64 bits Community Edition!!

I can (somewhat) understand not including PyPM in a "free" version - but if that's the case, then don't include it in the build!

Issues with Django South in PyPM

I installed both Django and South (a Django migration tool) with PyPM; however, upon using manage.py, the file wasn't picking up South's schemamigration or migrate commands. I ended up having to uninstall both Django and South with PyPM and instead use PIP to install those packages. After doing so, everything worked as it should.

Maybe there's a pathing conflict somewhere?

Excel WIN32::OLE Pivot table->chart Title

Hi @ all,

in recent days I try to talk about Perl with Excel 2007 (about WIN32::OLE).
I want to create a Pivot table + chart. But I couldn't create a chart Title. Please help me....

For a better understanding my perl code:

#! perl -w

use warnings;
use strict;

use Win32::OLE ;

my $excel = Win32::OLE->new('Excel.Application');
$excel->{'Visible'} = 1;

my $workbook = $excel -> Workbooks -> Add;

my $sheet = $workbook->Sheets("Tabelle1");
$sheet -> Range('A1')->{'Value'} = "Temp [°C]";
$sheet -> Range('B1')->{'Value'} = "Vcc [V]";

using syscall() function on windows 7

Hi, I installed ActivePerl on Windows 7 and I want to run the script as follows:

How can I measure time under a second?

In general, you may not be able to. The Time::HiRes module (available from CPAN) provides this functionality for some systems.

If your system supports both the syscall() function in Perl as well as a system call like gettimeofday(2), then you may be able to do something like this:

require 'sys/syscall.ph';
$TIMEVAL_T = "LL";
$done = $start = pack($TIMEVAL_T, ());
syscall( &SYS_gettimeofday, $start, 0) != -1

Problem building exe files with perlapp

Hi all,
I'm watching very often the following error during execution of perlapp:

Can't reopen 'xxxx.exe' for write: Permission denied at /Win32/PE.pm line 413.

When I start the same command a second time it is working in most cases.
After the error the resulting exe has the icon of perlapp and a start of the exe file results in a message that pdklib.dll is missing.

Gtk2::Socket

I am porting a Perl script to Windows 7. All works well except for
....
my $socket = Gtk2::Socket->new();
...
error message...
Can't locate object method "new" via package "Gtk2::Socket" ....

I am using the ppm package Gtk2 1.222. I can't seem to find anything about this on the web.

I want to attach the output window of Gnuplot to a VBox widget. Under Linux and on the MAC OS I can use

my $xxid = socket->get_id;

and pass it to Gnuplot as a hexadecimal string so that it exports its display to the Gtk2 VBox panel in my program.

jim...