Windows 7

Python 'turtle' script can't locate usable init.tcl

When I try to execute a simple turtle script I get the following error: "can't find a usable init.tcl in
C:/python34/lib/tcl8.6 C:/lib/tcl8.6 C:/lib/tcl8.6 C:/library C:/library C:/tcl8.6.1/library C:/tcl8.6.1/library."

I did the default ActiveState Python install, but none of these directories exist. (There is, however, a pyhton34/tcl subdirectory) There is a copy of init.tcl in python34/tcl/tcl8.6. Can someone tell me how to re-direct python to find the init.tcl?

5.20.1.2000 64-bit crashing @ IActiveScriptParse::InitNew in PerlSE.dll

ActivePerl 5.20.1.2000 when used as an Active Scripting host from DirectoryOpus (via a Rename function) is crashing in IActiveScriptParse::InitNew in PerlSE.dll.

ActivePerl 5.16.03 64-bit works fine.

If anyone from ActivePerl is listening, and are interesting is reproducing this, I'll supply more info.

Difficult to run script

Community,

I have the following problem:

I am trying to run some scripts at ActiveState ActiveTcl 8.6.3.1 (64-bit) and appear the message " can´t find package its exactly 1.1 while executing".

I know that scripts run in wish 8.4.2.2. I tried to download this version but I can´t find.

Thank you in advance.

Best regards,
Costa.

Missing DLL during win 7 install

I'd like install activeperl, I keep getting this message:

(see attached)

Would be help id the error said what file is missing

Known Issue Workaround: Python 3.4.1 Windows 64-bit IDLE (Python GUI) to fail to run

Symptoms: IDLE (Python GUI) fails to start from START Menu

PROBLEM:
Run IDLE (Python GUI) from START menu and get Window flash but nothing else. IDLE fails to start in a ActiveState Python 3.4.1 installation.

However, the Python Interactive shell runs properly from the START menu.

BACKGROUND:

This is a Windows 7 64-bit installation.

I installed ActivePython-3.4.1.0-win64-x64.msi (community edition) that was downloaded directly from the web site.

Ultimately, I installed from an Administrator privileged command line window using the msiexec /i command.

Install w/o admin rights

Is it possible to install Tcl on a Windows PC, without having admin rights? If yes, how?

Error Installing package 'math-random' could not locate a PPD file for package math-random

After installing Activeperl-5.16.3, I ran the followings in the DOS command prompt

ppm install math-random
ppm install statistics-distributions
ppm install archive-zip
ppm install file-copy-recursive
ppm install moosex-params-validate

I get the underlisted error for each of the comman e.g

Error Installing package 'math-random' could not locate a PPD file for package math-random.

I need help.
Regards,
Muyiwa

Looking for x64 Perl 5.12 binary

Is X64 Perl v5.12 is available from ActiveState for download?
I want to use Net::Server which is not available AFTER 5.12.

repository for text-unidecode

Any idea where I can find a PPM repository that has text-unidecode?

Can't find number-format package

I have been using ActiveState Perl for several years. I recently received a new computer, and installed ActiveState Perl 5.18.2. I then went to add the packages I use, and was able to add all of them except "number-format", which didn't show up in the package manager. Is that package no longer supported, or am I doing something wrong?

Thank you.