Windows 7

On Windows 7, @INC contains *nix Paths

Hello, I'm having an issue with a Windows instance of ActivePerl 5.24 x64.

As you can see, even though I'm on Windows, for some reason the @INC variable contains *nix paths.
I'm pretty sure that wasn't the case before but unfortunately I didn't take note of what I might have done that would change it.

Has anyone ever has such an issue before? What could be the cause and how could I fix it besides re-installing ActivePerl (which I can do but would rather not) ?

Please and thank you

Formating long strings with new line

Hello Forum,
Newbie here with a request for help with formatting. I need to trim and add newline at each "\" in a file location string that lies beyond the 60 character max for each line. Sample in attached file will be best explanation. Please notice the final file name is on its own line, 60 characters is max length per line and the indent is 3 blank spaces after the '('

Thank you for any assistance

Unsolvable error when running exe of fully functional perl

I have a little Perl script that works great in .pl form, but after running it through the PDK and launching the resulting .exe file I am faced with errors I cannot solve:

(removed by Moderator)

i have a isuue

hi everyone
The difference is in which math library they call.

Java, Google, and C# are using the MicroSoft C# floating point math library.

Tcl and Perl are using a C floating point math library.

Both libraries follow their respective standards, so both are correct. You may disagree with the way the standards have been defined, but that is one of the differences of C vs C#.

Error 12007 ActiveTCL installation.

i am trying to install active TCL in windows 7 and i get error 12007. then i acept and get the following description.

Warning 4156. Failed to correctly acquire vc_redist.x64.exe file: CRC error. Continue installation of ActiveTcl 8.6.6 Build 8606 (64 Bits)?

thanks in advance.

ActivePython in ALM VAPI-XP Script

Je souhaite exécuter du un script Python depuis HP ALM, de la même manière que je peux exécuter du code VBS. J'ai installé ActivePython sur mon poste local, et pourtant mon script ne s'exécute pas. Le code du script se résume à un 'print("test")'. Comment faire pour exécuter le script python depuis ALM?
Merci =)

I would like to run Python in ALM. I installed ActivePython on my local computer but the script does'nt run. The script is 'print("test")'. How can I run the python script from ALM???
Thank you =)

PAR Packer gives error

When running pp -o example.exe, I get the following:

Perl lib version (5.24.2) doesn't match executable 'perl.exe' version (5.24.0) at C:/Perl64/lib/ line 62.

What can I do to get the executable and lib to match? I have already tried uninstalling and reinstalling.


Problems installation ActivePerl

When I execute installation file (ActivePerl- after copy files I can see this message (on picture).

The destination folder (C:\Perl64\) is empty.

What is this? Where problems?

Installation process Active Perl 5.22, 5.26 is not succesfull too.

Please, help me.

can't install GnuPG::Interface

When I try to do this : cpan install GnuPG::Interface
either on Strawberry or Activeperl ( windows ) I get this error :
(I tried 32 bit version too )

CPAN: File::Temp loaded ok (v0.2304)
CPAN: YAML::XS loaded ok (v0.66)
CPAN: CPAN::Meta::Requirements loaded ok (v2.140)
CPAN: Parse::CPAN::Meta loaded ok (v2.150010)
CPAN: CPAN::Meta loaded ok (v2.150010)
CPAN: Module::CoreList loaded ok (v5.20170821)
Configuring A/AL/ALEXMV/GnuPG-Interface-0.52.tar.gz with Makefile.PL
which gpg ... 'which' is not recognized as an internal or external command,

Install Error ActiveTcl 8.5.18 on Windows 7

Hi all,

I am trying to install ActiveTcl 8.5.18 32-bit (just downloaded from ActiveState). When I double click I get an error that says "list element in quotes followed by ";"C:/Program instead of space". Can someone tell me how to get around this error so I can install?