Windows 7

Tk is still missing from AS perl 5.12 ppm for windows

Hello,

Does anyone have any information on when AS will be putting Tk back into either its install or available from the ppm instruction on windows 7?

I've done searches here, and found 3 items, both are months ago (8/25/10ish) but nothing since. They state there were some bugs still needing to be fixed. Hopefully, I am just missing something and that they are working on getting this resolved, and not just left hanging.

Any help would be appreciated!
Thanks!

ActiveTCL UDP install fails

I've been trying to install ActiveTCL UDP via teacup, but it keeps failing.

I've downloaded and installed the Win32 community version 8.5.9.0.
I'm using Windows 7 64-bit version.
I did have 64-bit active TCL, but it told me I needed a Business license to access the TeaCUP repository, so I changed to the Win32 Community version.

I get one of the 2 following errors.
Any help you can give would be much appreciated.
I would even install the files manually but I don't know how to access the package so I can install it manually.

    1 Failure to find:

strange account problems

everytime I log in, I get message:

Your community site username has been updated to baikis; previously this was set to gatavas

When I try to post a comment, I get:

Access denied
You are not authorized to access this page.

I tried to comment here:
http://community.activestate.com/xpi/uploader

Name a new file with stdin

Hi all,

Im a newbie to Tcl and need some help/advice. I’m writing a program that will connect to several Cisco routers run some commands and send the output to a text file.

I want to name the text file with the hostname from the router prompt. In my current script below, the text file is created but there is no name.

I think the problem may be in these 2 lines

gets stdin line
set fh [open $line.txt a+]

My script below

package require Expect

package require Expect

set username cisco
set password cisco
set expect_out(buffer) {}

set IP [open "ip.txt" r]

Trouble with PPM and @INC

I am installing the W3C Validator (validator.w3.org) which I have done many times before.
It requires SGML::Parser::OpenSP which is only available in precompiled form for 5.8, and compiling it is very hard (because of some dependencies).

Introduction out of the way, I installed ActivePerl in C:\Webserv\ActivePerl\5.8.9\.
PPM and the CPAN command line are adding modules to .\site\lib instead of .\lib.
I changed the #! in the script to #!C:/Webserv/ActivePerl/5.8.9/bin/perl.exe -T
and Apache seems to be executing it properly, but I get this error:

idle closes immediately

I installed ActivePython 2.7 (32-bit) on a Windows 7 box (x64). When I run idle from the Start menu, idle closes its window immediately. If I run idle from a cmd box, it seems to run fine:

> cd \ActivePython27
> Lib\idlelib\idle.bat

Any thoughts?

can't uninstall ActivePython...

I did an uninstall of ActiveState python both 64 & 32 bit versions, and even a reboot, and installed the FOSS (python.org)python (2.7).

But oddly enough, when I run python (cmd line) I still get ActiveState python reported:
E:\Plang\python>python
ActivePython 2.7.0.2 (ActiveState Software Inc.) based on
Python 2.7 (r27:82500, Aug 23 2010, 17:18:21) [MSC v.1500 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> copyright()
Copyright (c) 2000-2010 ActiveState Software Inc.

Windows 7 error

Hi, trying to install a package on Windows 7 and suddenly a five minute task became an all day odyssey.

This is the error I get:

"All activated install areas are read-only. You cannot currently install or remove packages. Try enabling the uninitialized Areas in the Preferences dialog"

For some reason, Windows does not allow me (even running Explorer as admin) to change the ownership on "C:\Program Files (x86)\Perl\lib" to Full Control for my username.

Has anyone else experienced this?

MSI and AS Package fail to install

I've been trying to install ActivePerl 5.12.1 for Windows 64.msi on Windows 7 and continue to get the following error:

Product: ActivePerl 5.12.1 Build 1201 (64-bit) -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action ConfigurePerl, location: C:\Windows\Installer\MSIAFFC.tmp, command: "C:\Perl64\bin\wperl.exe" "C:\Perl64\bin\config.pl"

Once the error occurs, the program rolls back and uninstalls itself.

PDF::Reuse::Barcode

I am trying to use ppm install PDF::Reuse::Barcode and it gives me an error:
ppm install failed: Can't find any package that provides PDF::Reuse::Barcode

I am Win7 x 64 - hence did not got the route of nmake.

ppm has always been my choice of installing Perl modules.

Can I use ppm to install it by downloading/unzipping the module on my
local server - any instructions?

Any help is greatly appreciated in installing this module,

TIA,
-sanju