Windows 7

'ppm repo sync' fails silently.

Hi all,

I'm trying to sync ppm with ActiveState repository on a fresh install of ActivePerl.

> ppm repo sync
Downloading ActiveState Package Repository packlist...done

> ppm log
2011-02-12T02:05:04 <6> [ppm:81] ppm repo sync
2011-02-12T02:05:04 <4> [Client.pm:256] Setting up schema for C:\Users\Bahman\Ap
pData\Local/ActiveState/ActivePerl/1203/ppm-MSWin32-x86-multi-thread-5_12.db
2011-02-12T02:05:43 <6> [Web.pm:102] GET http://ppm4.activestate.com/MSWin32-x86
/5.12/1203/package.xml ==> 200 OK (1225868 bytes in 38 sec - 32 KB/s)

lsearch -index fails on windows 7 NOT

My error. The failing tcl/tk is the cgywin version. I did not realize that this was there and that the PATH was picking it first.

Please ignore this...

The lsearch command fails with an illegal option -index on my windows 7 system. This same command works correctly on windows XP. Versions I have tried:
8.5.8.1 (on windows 7 and XP)
8.5.9.1 -32 bit (windows 7 only)
8.5.9.1 -64 bit (windows 7 only)

I used the same download of 8.5.8.1 on both the XP and the windows 7 machine with the XP working and the windows 7 failing.

Install was as admin.

Any help here?

Missing dependent -- winapiex.dll

Does anyone have an idea where I might find this missing library. I am using (begrudgingly and without option) Tcl 8.1 to load a dll that will open and retrieve data from MS Access. Dependency Walker shows it as a missing dependent library.

Many Thanks!!

missing perl module

The standard Net::Config module has an entry "use Mac::InternetConfig" for which there is no corresponding mopdule and I can't find the appropriate module through the PPM. Can someone assist it getting this done?

Installing Perl with NO Administrator rights

Hi, the installation documentation states that Perl will install for the local user only if the account running the msi installation package does not have admin rights. However, this is not the case when I try to install it. The install fails stating that it cant register perl for ALL users and rolls back. Why would it try to register Perl for all users if I clearly don't have admin rights? Do you have a work around? Command line install with some obscure argument?

Please help...

BRuno

Perl 5.12.2 Mime-Lite package

When using PPM I can not find the MIME-Lite module. Why is it not downloadable via PPM from the ActiveState repository?

thread::send to main thread fails?

Hi all,

I'am starting with threads, after experimenting I came across a few lines which crash/deadlock/whatever and I don't know why:

## prepare:
> package re Thread
2.6.7
> set tid [thread::create {thread::wait}]
tid00001940

## this command works fine as expected:
> thread::send [thread::id] {puts hello}
hello

## but this command fails - where in principle it should be the same as the one above?
> thread::send $tid [list thread::send [thread::id] {puts hello}]

thx

PPD Does not produce code to install for this platform [Windows 7 64 bit]

I am trying to install a module necessary to setup oinkmaster [dependency of SNORT] but I get this error: Any thoughts on how to get Update Snort Rules.pl installed without ppm?

C:\Users\Me\Downloads>ppm install Tk-804.028.ppmx
ppm install failed: The PPD does not provide code to install for this platform

C:\Users\Me\Downloads>perl -v

This is perl, v5.10.1 built for MSWin32-x64-multi-thread
(with 2 registered patches, see perl -V for more detail)

Copyright 1987-2009, Larry Wall

Can't install tcom package through teacup

Hi there,
I am a absolute newbee to Tcl.

I'd like to use tcom package of Tcl, as suggested in the following link. The purpose is to use emacs as an editor for Outlook.

http://wiki.tcl.tk/9198

However, when running the grabOutlookMessage.tcl function in the above link, there was an error:

can't find package tcom
    while executing
"package require tcom"
    (file "C:\Users\XXXX\Documents\grabOutlookMessage.tcl" line 9)

So, I figure the package tcom is not installed. Then I tried to installed the pakcage using teacup. Below is what I got: