Windows 7

Traceback ( most recent call last) when importing modules

Hi,

I installed ActiveState ActivePython 2.7 (32 bit) in Windows 7 32 bit machine.

I created a sample module and when i tried to import it im getting the below error.

Traceback (most recent call last):
File "", line 1, in
import sample
File "C:\Python27\sample.py", line 1
ActivePython 2.7.2.5 (ActiveState Software Inc.) based on
^
SyntaxError: invalid syntax

I checked for previous solution.

1) Tried rebooting my machine
2) Changed the environment variable

But still the issue is not resolved.

ActivePerl 5.14.2 Build 1402 (64-bit) change installation directory to c:\Program Files\Perl64 on Windows 7 64-bit

Having an issue with the ActivePerl-5.14.2.1402-MSWin32-x64-295342.msi. I am trying to configure the msi to install the files to the 64-bit Program Files folder in Windows 7 64-bit. The msi either installs to Program Files(x86)\Perl64 or C:\Perl64, but not in the 64-bit directory.

Upgrading to new version

Hello, I find very annoying when I upgraded to AP 5.16 that all my installed packages were lost. Is there a chance to save the list of existing packages before uninstalling previous perl version, the installing them back after major upgrade?

CPAN problem for installation of GraphViz2. Dependency on Perl6::Slurp

Hello all,

I am desperately trying to port some Perl code I developed on Apple to Windows, in order to make an .exe file. To do so, I need some modules.

I installed ActivePerl on Windows 7 (32 bit). That went just file. The first modules went allright as well. Problems occur when I try to install the needeed module GraphViz2.

GraphViz 2 needs some other modules. The install procedure with CPAN crashes on dependency Perl6::Slurp. dmake won't install (See log below)

PHP Debugging on Windows 7 in Komodo in 5 Minutes.

Question: 

Komodo won't use my PHP install for debugging! Why?

Answer: 

WARNING! Failed to configure PHP debugging.
WARNING! Could not determine PHP version number.

You might have seen these errors before. You were installing PHP on your system and trying to run it in Komodo. This FAQ is to help you jump some configuration hurdles. It's easier than you think...

  • Download and unpack the Zipped PHP to your machine. I put it in C:\php\.
  • Configure Komodo to use PHP interpreter or put it on the PATH.
    • Direct Komodo to the PHP interpreter:
      • Edit->Preferences->Language->PHP:Use this interpreter.
      • Click Browse.
      • Navigate to the folder you unzipped PHP into.
      • Select php.exe and click Open.
      • Komodo will configure and let you know that Debugging is ready.
    • Add C:\php\ to your system PATH.
      • To confirm that PHP has configured properly using the System Path variable click Check Configuration on the Komodo Start page. PHP should get two brand new green check marks

There you go. Now start writing some PHP!

NOTE: You do NOT need the Debug Pack download for debugging in Komodo. Just download the Zip.

CGI Cookie?

I noticed Active Perl does not have the CGI Cookie module. Is there any way to download this module manually and install it?

Also, for some reason when I run my script which has the use CGI::Cookie line, I do not get an error. If the module is not installed I should get an error. My script runs fine but will not set the cookie. I know my code is good because it runs fine on linux. Anyone know why this could be?

I am using active perl version 5.14 on windows 7.

Any help would be much appreciated.

Thanks in advance.

Can't download Komodo from website [CLOSED]

Since purchasing Komodo 7 last week, I have been unable to download the 7.0.2-70257.msi file from the Activestate website. My support email has received no response.

After clicking the download link, it takes around 20 seconds for any response from the server, and then the download fails, at best after retrieving a few kb of data.

I have no issues at my end with other downloads and there is nothing on our firewall I can see that is causing this problem.

Please can someone check the download server is working ok?

Thanks

Vanilla install - getting access is denied win 7 64 bit

Hello

Just started learning perl.. installed activeperl fine, trying to run my first file

perl> perl -w hello.pl
or
perl> perl hello.pl

both give

access is denied.

I am running from the cmd prompt.. c:\>

I have copied the file to the bin, and to the root of the activeperl folder.

I am setup as administrator on the local machine, and the file has permissions set to allow full control.

any pointers appreciated.

thank you.

PAR pp version mismatch in config.pm

First-time user of PAR pp. Getting error...

Perl lib version (5.12.4) doesn't match executable version (v5.12.0) at C:/Perl/
lib/Config.pm line 50.

Do I need to re-install perl?

command window:

C:\Users\Owner\NWCC perl>pp -o _hello _hello.pl
Set up gcc environment - 3.4.5 (mingw-vista special r3)
Perl lib version (5.12.4) doesn't match executable version (v5.12.0) at C:/Perl/
lib/Config.pm line 50.
Compilation failed in require at C:/Perl/lib/Errno.pm line 8.
BEGIN failed--compilation aborted at C:/Perl/lib/Errno.pm line 8.

Net::DNS crash on Windows 7 64 bit

I am using ActivePerl 5.14.2 and i am writing some script with Net::DNS module. When the script execute "use Net::DNS;", the program crash. I have un-install and re-install the module via ppm but it does not help. Any idea how i should fix this problem ?