Windows 7

Trying to Install PAR-Packer

Hello,

I am trying to add some new packages to my Perl Installation. I was successfully able to add the PostScript-Convert package However, when I try to install the PAR-Packer package, I get the error message:
ppm install failed: Can't find any package that provides PAR-Packer.
I am using the command provided by the ActiveState PPM Index so I am not sure what is going on. Any suggestions or help would be appreciated.

Regards,
Jim Crust
Elliott Company

ActiveTcl installation fails on Win 7 with a generic error message

I tried two versions currently available. Both fail the same way. Tried rebooting my PC to no avail. Tried running the installer from a command line as an administrator. Even tried redirecting the output to a log file, all to no avail.

rename function failing during a directory renaming operation

I have a small perl script that I want to use to rename directories / folders in a certain way.
If you put the directories name directly in the function it works but if you put a variable it fails.
See my code below:
Any ideas on how to fix this. Running on windows 7 and using 32 bit Activestate perl.

# test.pl
#use this script to rename folders to make it consistent naming style
# We will decide on our naming convention and style when this Perl script is working
# Aug 1, 2018
# test script to rename directory folder
#$file = "C:/folder1/" . "$file";

Problem installing ActiveState Python 3.5.4 on Windows 7 64bit

When I install ActiveState Python 3.5.4 on my Windows 7 (64bit) machine no shortcuts are created in Start Menu. I know that these shortcuts used to be created in earlier versions, and lack of them may point to some problem with the installation. Still, I have tried several times to uninstall and reinstall again and each time nothing was added to the Start Menu.

Does anyone know if this is an expected behaviour?

Thanks,

Tom

Perl Saxon

Hi

I am looking for a solution to use Saxon in Perl
we need to filter a lot of XML files with XSLT but the customer does not have software for that.
Want to know if it is possible with Perl!

thnx for your advice
Michael

DBD-MySQL with SSL

Has anyone gotten DBD::MySQL to work with SSL in ActiveState Perl? I have the following code:

use warnings;
use strict;
use DBI;

my $dbname = "database";
my $host = "127.0.0.1";
my $port = "3306";
my $user = "username";
my $pass = "password";
my $cakey = "ca-cert.pem";
my $clientkey = "win-key.pem.nopass";
my $clientcert = "win-cert.pem";

my $dsn = DBI->connect("dbi:mysql:dbname=$dbname;host=$host;port=$port;mysql_ssl=1;mysql_ssl_ca_file=$cakey;mysql_ssl_client_key=$clientkey;mysql_ssl_client_cert=$clientcert","$user","$pass",

On Windows 7, @INC contains *nix Paths

Hello, I'm having an issue with a Windows instance of ActivePerl 5.24 x64.

As you can see, even though I'm on Windows, for some reason the @INC variable contains *nix paths.
I'm pretty sure that wasn't the case before but unfortunately I didn't take note of what I might have done that would change it.

Has anyone ever has such an issue before? What could be the cause and how could I fix it besides re-installing ActivePerl (which I can do but would rather not) ?

Please and thank you

Formating long strings with new line

Hello Forum,
Newbie here with a request for help with formatting. I need to trim and add newline at each "\" in a file location string that lies beyond the 60 character max for each line. Sample in attached file will be best explanation. Please notice the final file name is on its own line, 60 characters is max length per line and the indent is 3 blank spaces after the '('

Thank you for any assistance

Unsolvable error when running exe of fully functional perl

I have a little Perl script that works great in .pl form, but after running it through the PDK and launching the resulting .exe file I am faced with errors I cannot solve:

(removed by Moderator)

i have a isuue

hi everyone
The difference is in which math library they call.

Java, Google, and C# are using the MicroSoft C# floating point math library.

Tcl and Perl are using a C floating point math library.

Both libraries follow their respective standards, so both are correct. You may disagree with the way the standards have been defined, but that is one of the differences of C vs C#.
thanks