Windows 2000 Pro / Server

DBD-ODBC and DBI 1.21

I've been forced to upgrade a server to Perl 5.10 to make it work with other modules. This machine is behind a firewall, and PPM cannot be made to work. I've had to download and install about 30 modules by hand, and have resolved all issues except one. DBD-ODBC is the last I need, and I'm stumped.

The issue is DBD-ODBC's requirement for DBI 1.21. A scan of these forums indicates that this is a popular problem. I've looked in the folders of downloadable zips for all Perl releases, and 1.21 does not exist. I've found:

5xx - 1.14
6xx - 1.34, 1.35, 1.37, 1.48
8xx - 1.35 - 1.602

ppm does not work after install

I just installed ActiveState Perl 5.10.0.1002 Win 32 and tried to launch ppm.

Either with the gui command or with the command line (ppm install PAR) I get the same error message :

ppm install failed: DBI connect('dbname=c:\winnt\PARAMâ•š~1\APPLIC~1/ActiveState/ActivePerl/1002/ppm-MSWin32-x86-multi-thread-5_10.db','',...) failed: unable to open database file(1)

I had exactly the same error with ActiveState Perl 5.8

The directory c:\winnt\... \1002 is correctly created, but nothing inside.

No DBD::Oracle module for ActivePerl 5.10.0.1002

Hi,

I've installed a fresh ActiveState Perl 5.10.0.1002.

Now I can't install the module DBD::Oracle via ppm because it isn't available for Perl 5.10.0.1002.

Where can I get a module version of DBD::Oracle for Perl 5.10.0.1002?

Thanks
Florian

Had to create Tk::XlibVtab unexpectedly at D:/Perl/lib/DynaLoader.pm line 253.

hi,

when i was suppose to use TableMatrix i get the error
Had to create Tk::XlibVtab unexpectedly at D:/Perl/lib/DynaLoader.pm line 253. i sent it for expert team but i not got any solution for this, will any one help me to come out of this???

thank you
--------
Mutturaj
--------

perl ppm4 installation problem

when i was about to install tk::tablematrix, i got the following error can any one help me out in this regard,

C:\Perl>ppm install Tk-TableMatrix.ppd
Unpacking Tk-TableMatrix-1.23...done
Generating HTML for Tk-TableMatrix-1.23...done
Installing to site area...failed
ppm install failed: File conflict; package Tk already provide C:/Perl/site/lib/a
uto/Tk/pTk/extralibs.ld

with thanks
mutturaj b

PPM can't download package

I just installed on my Win 2000 server, had set the http_proxy system variable as well. When I run my PPM GUI from command prompt, the status of PPM is as below:


Downloading ActiveState Package Repository packlist ... failed 502 Proxy Error ( The ISA Server denies the specified Uniform Resource Locator (URL). )
Downloading Bugzilla packlist ... failed 502 Proxy Error ( The ISA Server denies the specified Uniform Resource Locator (URL). )

location for PPM4 repositories

in the dreadful struggle to get net-ssh-w32perl installed, i have lost the location of the activestate repository (and all others except soulcage). the locations i can find on the web are not longer supported due to the SOAP issue. what is the correct location?

ppm repository for 5.6

I'm trying to use PPM for ActiveState Perl 5.6, and I've tried setting the
repository as specified in the faq
http://aspn.activestate.com/ASPN/docs/ActivePerl-5.6/faq/ActivePerl-faq2...
but "search" returns nothing when I try to use the ActiveState PPM repositories (I've tried the non-ActiveState ones and some of them do work but only have a very small set of modules).
Are the ActiveState repositories listed in the faq correct?

Chris

Multiple versions of perl

I have perl 5.004_02 on a windows 2000 server (SP4)
on directory c:\perl

Can I install perl 5.8 in a different directory (C:\perl58)
and avoid any compability issues?

.MSI - How Install ActivePerl 5.8 (Win32) ?

Hello -

I'm trying to install ActivePerl 5.8 (Win32), but the .msi is not recognized and get this error message. The error message I get is –

"This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package."

I'm installing it as admin., from the console off of the harddrive (not over a network).
Any work around?

Thanks, Ray