Suse / OpenSuse

PerlApp created executable not running with nonexec permission on /tmp directory

Hi,

We are using PerlApp to create freestanding executable from perl script.
When the executable built with PerlApp runs, it extracts its dynamic object files in the /tmp/pdk directory. However, it is not working on those systems which have some security permission like nonexec and non writable on /tmp directory.

Our application run on different ports and the problem is same on Window,Linu and AIX platform.

MIME::LITE mail sending: Not able to override sender details

When I try to send mail using MIME::LITE, it takes root@localhost as sender...How to override the setting? IN MAILX we have -r option to do the same...

Please help...

Komodo won't start on linux due to missing symbol

Question: 

Komodo won't start on linux, complains about gdk_window_get_visual symbol

Answer: 

On certain older (mostly RedHat based) linux distros Komodo will fail to start with the following error:

undefined symbol: gdk_window_get_visual

To fix this error you simply need to install the "gdk-pixbuf2" package. The name varies per distro, but searching for "pixbuf" should get you the right package name.

Cannot find itcl 4.x in ActiveState teapot ?!? (corrected)

Hi,

We try switching our application from 8.5.x to 8.6.4.0
We always build crossplatform using tclapp and the ActiveState repo (Linux -> Win) but we cannot get itcl 4.0 from the activestate teapot ?!?!
Only Itcl 3.4 can be found ...
An installed activetcl contains the itcl 4.0 package in the libs dir ...

Is it just missing ?
Or are we doing something wrong ?

More checking done .......

The itcl 4.0 is missing in the *basekits*, it is no separate package anymore !!!

It is contained only in base-tk-thread-8.6.4.0.298892-win32-ix86.exe

Corrupted Files when running the ActivePerl Linux installer

Question: 

When I run the installer, it reports that several files are corrupted. I see this error:
This installer package does not have the expected content. Please try to download a fresh copy of ActivePerl from ActiveState's website at activestate.com. If you still have problems please contact us at SupportEmail.

How do I fix this?

Answer: 

---Updated 03/18:
This FAQ applies to ALL ActivePerl Linux tarball installers.
A link to a current version has been specified solely for convenience
---

Trash the ActivePerl folder you extracted. Download a fresh copy, and do not open the Download with the Linux Archive Manager.

Archive Managers use an incompatible algorithm.

Go to a Terminal Window, and extract the file on the command line, using GNUtar instead:
http://docs.activestate.com/activeperl/5.26/get/linux/

Install fails with 3 files corrupt

openSuse 13.1 installed with latest updates.

Downloaded the latest Community perl version 5.20.2.2001

Extracted to home dir

Attempted to install. (./install.sh)

The following error comes up.

============

# ./install.sh
Checking package...
- file 'perl/man/man1/c2ph.1' corrupt.
- file 'perl/man/man1/perlbug.1' corrupt.
- file 'perl/man/man1/s2p.1' corrupt.

    This installer package does not have the expected content.  Please
    try to download a fresh copy of ActivePerl from ActiveState's website

trouble getting tclapp to find tbcload

Greetings:

I am having trouble getting tclapp to successfully generate a kit/pack for my application. It works when I don't try to compile into .tbc and it fails when i do click on compile .tcl files. I think tclapp cannot find tbcload. When I run Wrap i get an error that package "tbcload --is redirect" is not known. I have tried searching on web and locally on this forum for post about similar problems but found nothing that
really addresses the issue. The base that seems to give the best results (the one that works when I

right to left languages in text and menu items

Greetings:

I have a problem which to date I have been unable to resolve myself or by searching for helpful info about it on the web. My problem is displaying languages in tcl/tck (in
menu and text widgets) that are in languages that read from right to left. The 4 languages
I had hoped to provide in my application which are problematic are Hebrew, Aramaic, Farsi,
and Urdu. I used Google translate to do the translation and the translated text shows up
correctly in emacs (visually appears to go from right to left) so I think the translation

tbcload for legacy tcl versions (v. 7.6)

Hello,
is it possible to use tbc with tbcload in a legacy shell? I have an embedded tcl shell (version 7.6) that I cannot upgrade. I want to source tbc files, but the tbcload library is not compatible I think. I get the following error when I try to load the library: This interpreter does not support subs-enabled extensions. Is there a tbcload library for this tcl version? Or can I compile the sources maybe with stubs-disabled?

Thanks for your support!

Strange problem : @_ not working

Hi,

We recently installed ActivePerl (first 5.14 and then 5.18) and both versions cannot recognize @_ in the script. This is really strange and happens with ActivePerl only. The default perl (5.10) that comes with the distribution does not have this problem. Searched these forums and google too for this issue but couldnt find anything.

Would anyone be aware as to what is going on here ?

$tfileA="Testfile.dat";
open (IF,"<tfileA") || die "can't open $tfileA";
while (chomp ($r = <IF>)) {
print "Input row: $r\n";
split (/;/, $r);
XX = join (',', @_);
print "XX = [$XX]\n";