Solaris 10 ( X86 )

Active Perl support on Solaris 10 X86

Please share the link details where I can download the community edition of Active Perl for Solaris 19 (X86).

Not able to install Net::SSLeay perl module on Solaris x86 OS

On a Solaris x86 machine, we have Active perl 5.12 version installed.
We wanted to support SSL communication from Perl application.

When i tried to communicate to a HTTPS url i get the following error.
500 Can't locate object method "new" via package "LWP::Protocol::https::Socket"

On debugging, realized that we don't have the needed Net-SSLeay module installed. Hope that is causing this error.

When we tried to install Net-SSLeay using ppm, we get the following error.

We have Perl Business Edition license. I hope ppm should allow us to install the needed modules.

Tcl_CreateChannelHandler mask value on windows & Solaris

I have used Tcl_CreateChannelHandler to listen to the TCP socket handling.
Here the mask value returned is always 2 even after the TCP connection is closed by the other end on the solaris machine. But on a windows machine the mask value returned is 6 when the connection is closed. While creating the channel the option used is TCL_READABLE . Any idea how to know that the channel is closed without trying to read the channel on Solaris ?

Need to understand the matching between TCLpro 1.5 and ActiveTCL

Hello,

I am currently looking to understand how TCLpro 1.x (1.4 and above) matches the ActiveTCL 8.x versions for Solaris x86.

From the readme files, it appears that

"TclPro 1.4 bundles Tcl/Tk 8.3.2 and compatible versions of TclX, [incr Tcl], and (for Unix platforms only) Expect. You can download a free copy of TclPro 1.4 for:
• Windows 95, 98, NT 4.0 (Intel), 2000
• Solaris 2.5, 2.6, 7 (SPARC)
• HP-UX 10.20
• Linux (Intel, Red Hat 5.0+, SuSE 6.0+)
• SGI IRIX 6.3+"

not able to install ActiveTcl

Downloaded ActiveTcl8.5.5.0.287690-solaris-ix86-threaded.tar.gz and untared the .tar.gz file and tried to install in solaris 10 server. Not able install TCL.

while trying to install getting this error :

# sh install.sh
install.sh: ./payload/bin/tclsh8.5: cannot execute

ActivePython installation error on Solaris 10

I'm installing ActivePython 2.5.2.2 in my home directory on a Solaris 10 machine. I used gunzip to unzip and gtar to untar the tar.gz in my home directory. When running install.sh I get an error.

[user@server:~] $ cd ActivePython-2.5.2.2-solaris10-x86
[user@server:~/ActivePython-2.5.2.2-solaris10-x86] $ ./install.sh
./install.sh: ./INSTALLDIR/bin/python: cannot execute
[user@server:~/ActivePython-2.5.2.2-solaris10-x86] $

This is what is in the server's opt directory - would python already be installed here?

SUNWits SUNWrtvc
SUNWmlib SUNWvts

Solaris 10 post update using wrong perl

A long departed dev setup a Sol 10 box on which they installed ActivePerl and several modules. I had an OS corruption problem after a recent patch and had to upgrade with the latest update 5 which cured my problem.

However, the update obviously wiped out some config bits and now none of my perl scripts run unless I use the entire activeperl path.

I added activeperl to the path in /etc/profile and restarted. echo $PATH shows activeperl prior to /usr/bin but 'whereis perl' still shows /usr/bin/perl.

ssh to the box and 'su - root' results in activeperl as default for that session.

Problems with tls under solaris10/intel

My script works fine under windows and linux.
But under solaris 10 x86 (intel!) there is only trouble.

ActiveTCL 8.4.15 (ActiveTcl8.4.15.0.280619-solaris-ix86):
Segmentation Fault (core dumped)

ActiveTCL 8.4.17 (ActiveTcl8.4.17.0.283511-solaris-ix86):
couldn't load file "libtls1.5.1.so": ld.so.1: tclsh: fatal: libtls1.5.1.so: open failed: No such file or directory

ActiveTCL 8.4.18 (ActiveTcl8.4.18.0.284097-solaris-ix86):
couldn't load file "./libtls1.5.1.so": ld.so.1: tclsh: fatal: ./libtls1.5.1.so: hardware capability unsupported: 0x100 [ AMD_3DNow ]

Missing module "logging" on Solaris install

I'm trying to install ActivePython on Solaris X86. I downloaded the the installer to a Windows machine, expanded it and FTPd the resulting directory to the Solaris box. I then tried to run install.sh, and got Import Error: No module named logging at line 33 in ./_install/py

Any idea what I'm doing wrong?

Does the directory ActivePython-2.5.1.1-solaris10-x86 (which was expanded from the .tar.gz file I downloaded) have to be put in a specific location on the Unix box?

I'm an absolute beginner with Unix, so this is probably something very simple...

Thanks for your help.

Rowan

Installing ActivePerl 5.8 on Intel Solaris 9

I apologise for the tediousness of this question - I have tried
googling and the ActivePerl website with no luck:

I have previously installed ActivePerl 5.6 on a handful of Sparc
Solaris 9 boxes as follows:

pkgadd -a ActivePerl-5.6.1.638-sun4-solaris.admin -d
ActivePerl-5.6.1.638-sun4-solaris.pkg -r
ActivePerl-5.6.1.638-sun4-solaris.response ASperl

Where the ActivePerl-5.6.1.638-sun4-solaris.admin contained:

instance=unique
partial=nocheck
runlevel=nocheck
idepend=quit
rdepend=quit
space=quit
setuid=nocheck
conflict=nocheck
action=nocheck
basedir=default