Red Hat / Fedora Core

No libpython2.5.so installed with ActivePython 2.5.x?

Hi,

we have recently installed a software which requires libpython2.5.so.1.0. However, this library seems not to exist with ActivePython 2.5.x. Is there a way to install this library for ActivePython 2.5.x?

System: CentOS 5.2 and 5.3 on x86_64 and i386.

Cheers

frank

Converting from Traditional to Simplified Chinese

I support a website written in Tcl which displays data in Traditional Chinese (big5). We then have a Java servlet, using the translation code from mandarintools.com, to translate the result of a page request into Simplified Chinese. The conversion as specified to the translation code is from UTF-8 to UTF-8S; Java is apparently correctly translating the data to UTF-8 as it comes in.

DynaLoader object version 1.0801 does not match $DynaLoader::VERSION 1.0802

Hello,

Is there a way to update DynaLoader.pm from ActivePerl 5.10.0 from 1.0801 to 1.0802 (the version used in PDK) ?

I run normally my script using ActivePerl.

When I compile it using perlapp I receive no warnings.

When I execute compiled script I receive this error :

[myname@MyOS perl.db]$ ./demo

DynaLoader object version 1.0801 does not match $DynaLoader::VERSION 1.0802 at /DynaLoader.pm line 99.
BEGIN failed--compilation aborted at /DBI.pm line 157.
BEGIN failed--compilation aborted at demo.pl line 1

Install an older version

I'm trying to install an older version of perl but the system complains that there are newer versions already installed and it doesn't appear to do anything after that. I looked around for a 5.10 directory of some sort but couldn't find anything. I'm trying to install 5.8. How can I tell if 5.10 is installed and how can I remove it? If it has been removed (in it's entirity or partially) how can I tell and what do I have to do to fully remove it? Any help would be grealty appreciated.

ActivePerl on Linux

I've downloaded version 5.10 (rpm download) onto my Linux machine. I've put it onto a directory called /opt/pdk/ and in a shell I navigated to this directory and ran rpm -i ActivePerl......rpm. It never gave any feedback but there is now a directory underneath /opt/ called ActivePerl-5.10. If I do a perl -v at the shell prompt it still gives me version 5.6. First off how can I have the system recognize perl 5.10 as being the active version of perl (if I wanted or needed to)?

The ActivePerl(linux) does not support thread

Hi:

I tried to run thread and got this error:
This Perl hasn't been configured and builr properly for the threads module to work.

Any suggestion to solve this problem?

thx

Install issue: error while loading shared libraries: libstdc++.so.5

I'm trying to install ActivePython on my FC6-64bit box.
I'm getting the following error:
./INSTALLDIR/bin/python: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

I believe I have the lib installed, here is a listing from my /usr/lib directory:

@raptor ActivePython-2.4.3.11-linux-libcpp5-x86_64]$ ls -al /usr/lib/libstdc*
lrwxrwxrwx 1 root root     18 Feb  1 07:34 /usr/lib/libstdc++.so.5 -> libstdc++.so.5.0.7
-rwxr-xr-x 1 root root 733456 Aug 21 08:39 /usr/lib/libstdc++.so.5.0.7