Red Hat / Fedora Core

tclsh8.5 uninstall binary fails to uninstall over ssh

I was able to install the ActiveState tcl package over ssh, but now I cannot uninstall it.

-bash-3.00$ sudo ./uninstall
no display name and no $DISPLAY environment variable
    while executing
"load /home/eoj/tcltmp/ActiveTcl8.5.13.296436-linux-x86_64-threaded/uninstall/lib/tk8.5/../libtk8.5.so Tk"
    ("package ifneeded Tk 8.5.13" script)
    invoked from within
"package require Tk"
    (file "/home/eoj/tcltmp/ActiveTcl8.5.13.296436-linux-x86_64-threaded/uninstall/uninstall.tcl" line 37)
    invoked from within
"source      $startup"

RedHat and "set user" Tcl command

Question: 

We have Redhat 5 and 6, and use pam.ldap. We have noticed that ActiveTcl "set user [id user]" works with RedHat 5, but does not work with RedHat 6.

Answer: 

This results from a change in Red Hat 6 to the C library getpwuid(uid).

ActiveTcl is still built on an older kernel for backwards compatibility, and a program using getpwuid(uid) from an older kernel will not run correctly on Red Hat 6.

The problem can be worked around using:
set user [exec logname]

instead of

set user [id user]

RPM for ActiveTcl?

Has anybody deployed ActiveTcl via Puppet? If so how? I was hoping to find an RPM to install ActiveTcl but one doesn't seem to exist.

a very Simple question which I can't find the answer

Hello,

I need to use WordNet, and as requirements I need to install Tcl/tk.
I downloaded and then installed tcl8.5.9, but I couldn't install tk8.5.9. when I type ./configure this is my configure file:

-------------------------------------------
checking for tclsh... /usr/local/bin/tclsh8.5
checking for tclsh in Tcl build directory... /home/Ehsan/Tcl-Tk/tcl8.5.9/unix/tclsh
checking whether to use symlinks for manpages... no
checking whether to compress the manpages... no
checking whether to add a package name suffix for the manpages... no
checking for gcc... gcc

itcl::class command causes itcl8.6 (8.6.0.0b5) to segmentation fault

Hi,

I recently installed ActiveTcl8.6 (ActiveTcl8.6.0.0b5.294318-linux-x86_64-threaded) and every time I try to source a tcl class file, it causes my tclsh or tkcon to segmentation fault. I'm not sure what to do to get around this problem. Any help would be appreciated.

Note that this ActiveTcl package include Itcl 3.4.

Thanks,

Leon

Iwidgets and activetcl 8.6

I installed ActiveTcl 8.6 on a 64bit fedora 14.
I tried package require Iwidgets and nothing happen. Then I read same pages and run
./teacup install --with-recommends Iwidgets

and then every time i exec package require Iwidgets I obtain

segmentation fault .......

Issues complining packages with 8.6 - Stub Issues

This is one example of trying to compile packages using ActiveState 8.6. and getting stub errors.

Google was not much help...

MySQLTCL Package

Not sure what is going on???

Any help??

[root@dama mysqltcl-3.05]# make

Tcl 8.5.9 Dev Kit 5.2.1 Installation Problem

Trying to compile an application on Tcl 8.5.9 that formerly compiled on version 8.4.6. I'm not sure what version of the dev kit was installed as I did not do the install. It appears that it may be 3.1. It was installed into the same directory as Tcl, this is evident by virtue of the fact that the compiler, debugger, etc. are located with the bin directory of the Tcl install.

tdbc installed via teacup not found

I installed Active Tcl into /opt and ran teacup from its bin directory to install tdbc and tdbc::mysql. It can actually be found in the lib directory, but using 'package require tdbc::mysql' I get the message "can't find package tdbc".

What is my problem? Did I overlook something?

-Christoph

ActiveStateTcl8.5 on Linux - is autoexpect supported

Hi,

I have installed ActiveTcl8.5 on a Red Hat Linux box.

I can execute simple expect scripts after issuing

% package require Expect

How do I install / run autoexpect? ( I'm a bit of a novice with Tcl)

Thanks in advance for your help.

Shaun
Brisbane, Australia