Red Hat / Fedora Core

./perl/bin/perl: /lib64/ version `GLIBC_2.14' not found (required by ./perl/bin/perl)

Can't install the latest Perl on Oracle Unbreakable Linux

cd ActivePerl-
[xxx ActivePerl-]$ ./perl/bin/perl
./perl/bin/perl: /lib64/ version `GLIBC_2.14' not found (required by ./perl/bin/perl)

At the moment have installed libc 2.12 and yum update tells me that it is the latest version available.

Can't find libc 2.14 in the repos. Could somebody tell where to get it?

[Tcl/Tk 8.6]Tk window(toplevel) became unresponsive while launching tk_messageBox on Linux platform

Tcl/Tk Version Information:
Platform: Linux
Tcl Version: 8.6.7
Tk Version : 8.6.7

Issue: [Tcl/Tk 8.6]Tk window(toplevel) became unresponsive while launching tk_messageBox in Linux platform

Step to Reproduce issue:
1. create a sample tk window using toplevel command with a button.
toplevel .window
button .window.button1 -text "Ok" -command "puts hello"
pack .window.button1
(At this point everything works fine, .window and .window.button1 works fine)

2. open tk_messageBox. Now after launching tk_messageBox, .window and .window.button1 is became

Is GLIBC_2.14 a minimum requirement? - Would GLIBC_2.17 be supported then?

I am having a similar issue to nissam in post 12912 where they are having difficulty installing ActivePerl due to the requirement for GLIBC_2.14.

We are only able to install either GLIBC_2.12 or GLIBC_2.17 (available in the next RH release).

Would ActivePerl 5.2x support this GLIBC_2.17 (i.e. a minimum requirement for GLIBC_2.14 or is GLIBC_2.14 a specific requirement)?

We won't be moving to Ubuntu or other distros as suggested in the previous staff post.


Looking for 64bit version of tbcload1.7 for Linux

I have been using the tbc compiler with ActiveState TclDevKit 5.4 on a 32 bit system and this has been working well. I can use the loader and it loads the bytecode fine. I am migrating my development to a 64bit system and it will not allow me to use the tbc loader I have been using and gives me the error "wrong ELF class" which usually denotes using 32bit code on 64bit system.

I installed the DevKit for x86_64 however I cannot find a compiled version of the loader. Please advise if this loader is still distributed with the x86_64 version. If so, where is it located.

DBD::mysql Module Cannot Locate MySQL Socket

I've used ActivePerl's PPM to install the DBD::mysql module. For some reason, when attempting a database connection in my script using localhost (unix socket), the module cannot locate the mysql.sock file. It is looking for it in /tmp/mysql.sock. That does not seem like a logical location. I know where the mysql.sock file is. I even sym-linked the socket file to the /tmp directory. No luck. Interestingly, using the loopback (tcp/ip connection), the module finds the mysql socket with no issues.

Error /opt/pdk/bin/perlapp not recognized as a PDK tool

I'm trying to setup the PDK 9.5.1 on RHEL 7 64 Bit. When I use Acivestate Perl 5.22 as the designated Perl for the PDK I get the GLIBC 2.14 error when running the compiled perl. So I installed the Perl 5.24 for Linux 64 bit. When I try to use that level of perl, and specify /opt/ActivePerl-5.24/bin/perl on the PerlApp UI I get an error popup that says /opt/pdk/bin/perlapp is not recognized as a PDK tool. Any idea why I get this error please?

PerlApp created executable not running with nonexec permission on /tmp directory


We are using PerlApp to create freestanding executable from perl script.
When the executable built with PerlApp runs, it extracts its dynamic object files in the /tmp/pdk directory. However, it is not working on those systems which have some security permission like nonexec and non writable on /tmp directory.

Our application run on different ports and the problem is same on Window,Linu and AIX platform.

Error installing ActivePerl 5.24 on CentOS6

I was wondering if there is a way to install the new ActivePerl 5.24 on a CentOS6 server. I'm getting an error:

"perl/bin/perl: /lib64/ version `GLIBC_2.14' not found (required by perl/bin/perl)".

Does this mean that unless I am running CentOS7, I can no longer use new versions of ActivePerl as they become available? I have dozens of mission critical customer servers running CentOS6 so its not possible for me to simply switch operating systems.


expect cannot handle string longer than 4096, how to fix it?

demo as follows:

$ expect -f expect_test
omit output...
$ echo $?

$ cat

Can I move the ActivePerl top level directory after installation?

I am running ActivePerl 5.18 on all of my CentOS hosts and use the default installation directory of /opt/ActivePerl-5.18. However, I am wondering what the consequences would be if I renamed or moved the directory to say, /usr/local. Any insight at all would be greatly appreciated.