OS X 10.5 (Leopard)

Mac OS X 10.5 (Leopard)

installation of tcl8.5.11

I am trying to install tcl8.5.11 for use with aria2.3

On execution of:

make -C tcl${ver}/macosx

lots happens but in the end it fails with:

tcl8.5.11/unix/../unix/tclAppInit.c
cc1: error: unrecognized command line option "-mdynamic-no-pic"
make[3]: *** [tclAppInit.o] Error 1
make[2]: *** [build-tcl] Error 2
make[1]: *** [tcl] Error 2
make: *** [develop] Error 2

Any help!

Bad CPU type in executable

Beginner question on running ActivePerl on a PowerMac G5.

I downloaded ActivePerl 5.14.2 and installed it on my OS X 10.5.8 PowerPC mac.

I wanted to ask why I get the error: Bad CPU type in executable

When I type: usr/local/Activeperl-5.14/bin/perl: Bad CPU type in executable

Thanks!

Feature Request for Mac OS X Install PPC

Could the creators of the install script for Mac OS X prevent the installer from installing Intel binary in to a PPC Mac System? It seems like a good thing for people that may be confused about downloading the binary and installing into Mac OS X Tiger & Leopard.

Installing ActivePython on Snow Leopard

I'm running Mac OSX Snow Leopard. I installed ActivePython 2.6.2.2. However when I run terminal and type "Python" I get a response for 2.6.1 which I believe is the default installed before ActivePython.

I have found activestates ActivePython installed in "/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python\" while the default is in "/System/Library/Frameworks/Python.framework/Versions/2.6/Resources/"

I don't quite understand how this is behaving. I thought if I typed python in terminal with active python installed, I should see 2.6.2.2 , is this wrong?

Python imports old Tk 8.4 instead of 8.5

Hi all

I feel I have looked everywhere, so hopefully this is not a redundant question..

I am usually pretty good with computers. I only recently started working with python and in my struggle to get it up and running I have become very very confused... and to be honest I'm not a 100% sure what versions of what I have installed. This is what I know:

-I am running Mac OS 10.5
-Python 2.5 was pre-installed
-Due to my trigger happy fingers I came to install python 2.3 :P
-I then downloaded Python 3.1 and installed it
-Read that I needed tkinter so..

DBD-mysql in osx issues

I've just started using activeperl in windows xp and I haven't had an issue finding the needed modules in ppm. Everything works great. I wanted to start using it on my macbook pro but there seem to be quite a few missing from the activestate repo. I'm needing DBD-mysql. I found a few other repos listed in posts on here but they seem to only have windows modules:

http://theoryx5.uwinnipeg.ca/ppms/
http://www.bribes.org/perl/ppm
http://trouchelle.com/ppm/

Any help on getting DBD-mysql up and running? OSX repos? I've messed around with CPAN but haven't had much luck. Thanks.

Spreadsheet-WriteExcel installed but prog in komodo ide can't locate it

I'm new to working with PERL and just installed ActivePerl so sorry if this is a quick fix. =) I did have this program running on a debian box the other day. I have activeperl 5.10.0.1005 installed and have installed Spreadsheet-WriteExcel through PPM but when komodo hits this:

use Spreadsheet::WriteExcel;

This is what I'm getting:

how to complete install on MacOSX

Hi -

I just downloaded and installed ActivePerl on my Mac. I now have the standard perl and the newly installed ActivePerl at /usr/local/ActivePerl-5.8.

How do I make ActivePerl be the default perl on MacOSX? I used to use the "use.perl port" tool on freebsd, but don't see that option here.

thanks,
gary

problem installing 5.10 on MAC OS X

Hi,

I am new to Mac (longtime Windows user). I am trying to install ActivePerl 5.10. Everything seems to go fine, but I can't find the program in my Applications area. I saw something in the documentation that suggested it might have installed into my user area, so I looked there and I can find the ActivePerl image file, but not the program itself. There is also a 100 mb file (or so) that when I click on it just get me the installation page again.

Problem with DB_FIle - Solved

I'm trying to carry out some remote debugging with some Perl CGI scripts. My Mac with Leopard already had Perl installed but I needed some other Perl modules, including DB_File, so I installed ActivePerl in a separate directory, choosing the default one of /usr/local/ActivePerl-5.8/bin, and used PPM to install the missing modules. I changed PATH so that this directory came at the beginning.

I have a script that checks that the extra modules that I need are loaded but when I include the DB_File as one of the required modules I get the following dyld error: