Linux

ActiveTcl 8.4 Community Edition for Linux with threading support

Hi,
I noticed when trying to download ActiveTcl 8.4 for Linux that only non-threaded version is available for Linux whereas for Windows threaded version is available. While looking at my options, I found the following information at (http://wiki.tcl.tk/1875):

Threading / Thread-enabled

- In ActiveTcl 8.5 the Tcl core is thread-enabled for all platforms.
- In ActiveTcl 8.4 the Tcl core is thread-enabled for Windows and OS X only.

mod_perl and linux

I have installed mod_perl via yum and configured it under my Linux:

2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:39 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

All the libraries I am using are under:

/opt/ActivePerl-5.12/lib

I've setup apache to start and include that directory in my @INC. It's there, I've validated it.

Now when I try to send a call via SOAP to the handler I am receiving the following:

/usr/sbin/httpd: symbol lookup error: /opt/ActivePerl-5.12/lib/auto/List/Util/Util.so: undefined symbol: Perl_Istack_sp_ptr

TCL in NS2

Hi all,
I am Meher. I wrote a TCL script in NS2 which involves running multiple multiple Voice and Video sessions. I am not able to troubleshoot one error since two weeks. I would be thankful if anyone can help me please. I am ready to send documents if possible.

thanks,
Meher

[SEO SPAM] Install Perl Module - Automated Script

[No delete option available, submitter has been blocked - EP]

Nowadays It will be very difficult to install Perl modules to our system. We need to follow certain recursive steps for each and all of its dependent modules.

This is an automated script developed in Perl to install Perl modules and all of its dependent modules with in a single step.

Released under License: GNU General Public License (GPL)

Download the script from

http://sourceforge.net/projects/moduleperl/

or

[url deleted]

Syntax:

perl installer module1 module2 etc

or

Pcap feature for Active TCL

Hi,

I want to implement Live packet capture for my application, Is it possible to implement Pcap(Packet capture functionality) feature in Active TCL?
I want to know which TCL extension is required to accomplish this.
I tried to use TCLPcap 2.0.0,but it is not working.
Please guide me regarding this.

Thanks,
Sivabalan K

DynaLoader object version 1.0801 does not match $DynaLoader::VERSION 1.0802

Hello,

Is there a way to update DynaLoader.pm from ActivePerl 5.10.0 from 1.0801 to 1.0802 (the version used in PDK) ?

I run normally my script using ActivePerl.

When I compile it using perlapp I receive no warnings.

When I execute compiled script I receive this error :

[myname@MyOS perl.db]$ ./demo

DynaLoader object version 1.0801 does not match $DynaLoader::VERSION 1.0802 at /DynaLoader.pm line 99.
BEGIN failed--compilation aborted at /DBI.pm line 157.
BEGIN failed--compilation aborted at demo.pl line 1

IndexError: list index out of range

Question: 

I'm getting "IndexError: list index out of range" when I try to install Komodo on Linux. Why?

Answer: 

The Komodo installer is a gzipped tarball. It needs to be decompressed and untarred with g(un)zip and GNU tar compatible tools ('tar xzvf ...' should work on most systems).

Unpacking the tar.gz file using some other tools (such as WinZip) may cause the archive to be corrupted or missing components, leading to install errors like this one:

install: Installing ActiveState Komodo to '/opt/Komodo-IDE-4'...
Traceback (most recent call last):
File "./support/_install.py", line 620, in <module>
sys.exit( main(sys.argv) )
File "./support/_install.py", line 607, in main
interactiveInstall(suppressShortcut)
File "./support/_install.py", line 506, in interactiveInstall
install(installDir, suppressShortcut)
File "./support/_install.py", line 515, in install
destDir=destDir)
File "./support/_install.py", line 397, in _install
"libpython?.?.so"))[0]
IndexError: list index out of range

If you are seeing errors like this, try re-downloading the tar.gz file and unpacking it with 'tar -xzvf Komodo-<version>-<platform>.tar.gz'.

ActiveTcl installation on Linux

Hi folks,

I've installed ActiveTcl 852 on my Linux, Fedora 8, through the GUI installer.
It was installed in /opt/ActiveTcl... (default).
The tcl lib got installed in /opt/ActiveTcl../lib and /include

Consequently, I cas unable to compile and link easily my C code with tcl, since gcc could not find the tcl.h file, nore the lib tcl. I've had to add manually links in /usr/local/include and /usr/local/lib.

This is strange to me. I thought that the ActiveState installer would / should have added such links for me, so that the tcl lib is found immediatly by the compiler.

ActiveTcl for machines other than x86 architecture

Which version of ActiveTcl is compatible for SuSE linux installed over powerpc architecture?

Why doesn't Ctrl-Shift-U lower-case a selection on Linux

Question: 

The Code menu gives a keybinding of "Ctrl+Shift+U" for "Make Lowercase", but when I try this, the selection is replaced by the letter "u" and the cursor no longer moves. What's going on?

Answer: 

Some Linux platforms use the Shift-Ctrl-U as an signal to move into an in-place Unicode Input Method Editor (IME), and Komodo can't override that to implement the lowercase-selection command. However this isn't the case on all Linux platforms, and we can't have Komodo determine it at runtime either.

If you're on Unix, you can use the Preferences|Editor|Key Bindings to assign this command to a new key binding; I found [Ctrl K + L] is as memorable as the default key sequence, and it isn't being used.

If you do end up in this IME mode, you can press the Escape key to get out of it.