Gentoo

PerlApp created executable not running with nonexec permission on /tmp directory

Hi,

We are using PerlApp to create freestanding executable from perl script.
When the executable built with PerlApp runs, it extracts its dynamic object files in the /tmp/pdk directory. However, it is not working on those systems which have some security permission like nonexec and non writable on /tmp directory.

Our application run on different ports and the problem is same on Window,Linu and AIX platform.

telnet spawn_id not found in debug mode (Komodo)

Hi!

New to tcl and trying to debug a script in Eclipse. The script works fine when I run it (with tclsh) but when running in debug mode with ActiveState Komodo debugger spawning a telnet session I cannot get a spawn_id:

    spawn telnet $nodeIp
    set spawnId $spawn_id

Execution error 206: can't read "spawn_id": no such variable
    while executing
"set spawnId $spawn_id"

How do I setup Eclipse to get the spawn_id? I found an old post about a fix for this (2008...) but I am running the latest version: 9.3.2.

dbgp_tcldebug -V

Corrupted Files when running the ActivePerl Linux installer

Question: 

When I run the installer, it reports that several files are corrupted. I see this error:
This installer package does not have the expected content. Please try to download a fresh copy of ActivePerl from ActiveState's website at activestate.com. If you still have problems please contact us at SupportEmail.

How do I fix this?

Answer: 

---Updated 10/18:
This FAQ applies to ALL ActivePerl Linux tarball installers.
A link to a current version has been specified solely for convenience
---
There are two possible causes.

1) If you used the command line "tar" to extract the archive, and tar reported this:
"tar: Removing leading / from member names"
the version of tar you have installed is removing leading slashes by default as a security measure. This will break the ActivePerl installer. Delete the extracted folder and run tar with different options.
"tar -zxPf (filename for the ActivePerl installer tarball with extensions.)"

2) If you allowed your browser to extract the tarball, it will have use the Linux Archive Manager. Trash the ActivePerl folder you extracted. Download a fresh copy, and do not open the Download with the Linux Archive Manager.
Go to a Terminal Window, and extract the file on the command line, using GNUtar instead:
http://docs.activestate.com/activeperl/5.26/get/linux/
You may still hit the leading slash issue if your tar has that default behaviour.

PERL MODULE MANAGER

PERL MODULE MANAGER - perlmod Version 1.1.0
To Install perl modules and all dependent modules,Uninstall perl modules,List all perl modules in system,Search for a perl module in cpan.org and system,List all files of a perl module and Details of a perl module.

---------
Features:
---------

a) We can install any number of modules in a single command. Also all dependent modules of these modules insta
lled simultaneously.

b) Uninstall modules from the system

c) Print all files related to a module

d) List all perl modules installed in the system

libperl uncompatible while compiling

hi
im using
ActivePerl-5.8.9.825-i686-linux-glibc-2.3.2-288577
and
PDK v7.2
but whenever i try compiling with perlapp i get this error

libperl.so at '/opt/ActivePerl-5.8/lib/CORE/libperl.so' is not compatible with the PDK.

i even tried replacing that lib with one from pdk/lib in vain

any ideas?

DBD:ODBC + ActivePerl

Hi,

I have been looking at a problem one ouf our customers was having using ActivePerl to connect via DBD:ODBC to our SQL Server driver on Linux. After investigating, the problem seems to be that the version of iODBC you have built your distribution with expects the W (wide) functions (SQLDriverConnectW, SQLConnectW) to use four byte unicode. Unfortunatly that will fail with just about every ODBC driver out there that exports the W functions, as most of those will expect 2 byte wide characters, just the same as on Windows