All / Any

Thinking about an upgrade?

Please see this FAQ on which ActivePerl releases are compatible with the final release of PDK.

https://community.activestate.com/faq/finalversionpairingsPDK

Final Version pairings for ActivePerl with Perl Dev Kit

Question: 

I want to upgrade ActivePerl and my Perl Dev Kit. What's available?

Answer: 

You may have already seen the announcement... Last year, ActiveState announced that the direction for the company's future will be OpenSource Languages.

http://www.activestate.com/blog/2016/11/activestate-open-source-language...
http://www.activestate.com/blog/2016/12/open-source-languages-company-up...

Proprietary tooling for certain languages is not part of the OpenSource Languages Company future. Sales of both of the Dev Kit tools sets were discontinued at the time of those announcements. New licenses for PDK and TDK will not be available as separate products.
http://www.activestate.com/perl-dev-kit

Engineering and Development time and resources were immediately priorized for updating the existing language distributions. In 2017, work is starting on the new languages. Work was stopped on PDK, and that means that there will not be a PDK 9.6.

Existing copies of PDK 9.5.1 cannot use the latest releases of ActivePerl. The 2203 and 2204 builds are not compatible, and all 5.24 versions remain incompatible with the final release of PDK 9.5.1.

2202 is the last compatible ActivePerl, except on OS X.

For OS X, the 9.5.1 release of PDK was created on OS X 10.5. Every PDK must have a 100% binary compatible ActivePerl. ActivePerls switched from building on OS X 10.5 to building on OS X 10.9 at 5.22.2.2202 and are now 64-bit only. These two factors are responsible for the unresolvable symbols error message. Since there will not be a 9.6 that is also built on OS X 10.9, the 2201 release is the last ActivePerl that is compatible.

Upgrading from Perl < 5.14 using PPM vs upgrading from Perl >= 5.14 using PPM

The documentation for ActivePerl 5.8 through 5.12 still describes a process that only worked when upgrading from 5.6.x, or 5.8.8.817 and older, to a newer Perl.

The CPAN/PPM module "PPM::Profile" is only compatible with Perls using the old PPM version 3.x. It will not create a usable file from a Perl with PPM version 4.x.

Users upgrading from a 5.8 through 5.12 Perl should use a script instead of the old module. Thanks to user "berniec" for posting an example script in the Installation forum:

https://community.activestate.com/node/10420#comment-27084

Known Issues in recent releases

This posting will track known issues with the current set of Community Edition releases.

- perdoc errors On Windows
Versions affected
5.24.1.2402 and 5.22.3.2204 (Versions using perldoc v3.27)
Components affected: perldoc
Symptoms: perdoc errors with "invalid argument: -R"
Workaround: perldoc -T (document) | more
Bug Status: Core Perl bug
Fix Availability: Fix expected in the next ActiveState releases for 5.24 and 5.22.

- MicroSoft Compilers are incompatible -
Versions affected:
All 5.18, 5.20, 5.22, 5.24

Tcl Dev Kit 5.4 Known Issues

Known Issues for TDK 5.4.x

-Release Notes information on changes for 5.4.0 will not be available.

-Installation Guide/System Requirements
Windows versions should include 7, 8, 10, 2008, and 2012.
OS X versions should be 10.5 to 10.10

-All versions: Code Profiling
Memory usage is not capped. If the profiler is left running for long periods, the accumulating statistics will eventually exhaust the system memory. Do not run the profiler for extended periods.

-OS X compatibility.

HeartBleed vulnerability and ActivePerl

Question: 

Is my Community/Business/Enterprise Edition version of ActivePerl vulnerable to HeartBleed?

Answer: 

ActivePerl Community/Business Editions which, as shipped, are affected:
- 5.14.4.1405 - upgrade to 5.14.4.1406 (Business Edition only) or 5.16.3.1604 to fix
- 5.16.3.1603 - upgrade to 5.16.3.1604 to fix
- 5.18.1.1800 - upgrade to 5.18.2.1802 to fix
- 5.18.2.1801 - upgrade to 5.18.2.1802 to fix

Modules supplied through PPM are unaffected.
Modules compiled locally must be reviewed locally for vulnerability.

Enterprise Editions can be distinguished from Community/Business Editions by the presence of an additional fifth number before the six digit build number/version control number.
ActivePerl Enterprise Editions which, as shipped, are affected:
- 5.8.9.829.9 through 829.12
- 5.10.1.1009.9 through 1009.12
- 5.12.5.1206.2 through 1206.5
- 5.14.3.1404.2 through 1405.3
- 5.16.2.1602.2 through 1603.3

New Enterprise releases have been issued and can be located under the 2014Q1.1 folder.

HeartBleed vulnerability and ActivePython

Question: 

Is my Community/Business/Enterprise Edition version of ActivePython vulnerable to HeartBleed?

Answer: 

No Enterprise versions of ActivePython are vulnerable.

No Community/Business Edition versions of ActivePython 2.x and no Community/Business Edition versions of ActivePython 3.0, 3.1, and 3.2 are vulnerable to HeartBleed.

Only Community/Business Edition ActivePython 3.3.2.0 and 3.3.4.1 are vulnerable.
An updated 3.3 release will be needed to address the vulnerability.

Tkx manuals or tutorials?

Tkx is a thin wrapper around Tcl/Tk. This means there isn't much need for documentation specific to Tkx because everything is covered in detail by the Tcl/Tk documentation. What is helpful is a tutorial showing how to call Tcl/Tk using Tkx. Fortunately, the Tk tutorial provides lots of examples in several languages. The Perl examples use the Tkx module.

http://www.tkdocs.com/tutorial/

Perl CVE-2013-1667 Input Rehashing Denial of Service Vulnerability

Does this apply to active perl 5.14.2.1402-MSWin32-x64-295342? I know that it applies to the more generic version of Perl 5.14.x. Will ActiveState release a product specific patch to address this issue?

PPM Access for Business Edition ActivePerl versions

There is an FAQ posted under the ActivePerl heading regarding 401 Authorization messages generated by PPM.

http://community.activestate.com/faq-list?tid=50