A bug found in Plotchart package in the currently published ActiveTCL Linux 64 bit community edition.

Posted by superlinux on 2013-04-25 17:40

A bug found in Plotchart package in the published ActiveTCL Linux 64 bit community edition (file name in the downloads page is ActiveTcl8.6.0.0.296563-linux-x86_64-threaded.tar.gz).

when you issue:

% package require Plotchart

you get : conflicting versions 2.1.0 and 2.0.1 . and it cannot include Plotchart package.

I consulted #tcl channel of freenode. Thanks to "Johannes13" he solved it.

Open this file "plotchart.tcl" in your installation of ActiveTcl 8.6 directory. I have my directory in Linux as /opt/ActiveTCL8.6/. so I open:

/opt/ActiveTcl-8.6/lib/teapot/package/tcl/lib/Plotchart2.1.0/plotchart.tcl

and go to the very last line in the file "plotchart.tcl" and change the line from:
package provide Plotchart 2.0.1

to be :
package provide Plotchart 2.1.0

that's all.. it was just a silly typo! :)