Stackato Imports/Exports in 2.10 failing due to being older than 2.2

Posted by lorned on 2013-04-16 09:56
OS: All / Any | Product: Stackato | tags: 2.10 error export Import patch stackato
Question: 

Why are my Stackato import/export actions failing to complete when I am importing into 2.10? The error message states 'ERROR: Unable to import/export with a Stackato version older than 2.2, please import/export manually'

Answer: 

Stackato 2.10 environments will require a patch to enable imports/exports to work as expected. You will need to apply the following to all of the nodes in your cluster:

1) Download patch from http://get.stackato.com/patch/2.10/stackato-2.10.4-import-fix.sh
2) Upload patch to your 2.10 node(s).
3) Execute the patch via 'sh stackato-2.10.4-import-fix.sh' from the directory you uploaded the patch to.
4) Repeat for all nodes in cluster

After applying this patch you should be able to run the import/export command without this error.