matplotlib 1.2 available, but not on PyPM

Posted by bill_ on 2013-02-08 11:16
Forums: PyPM (discontinued) | OS: All / Any

matplotlib 1.2 is now available

This version of this heavily used package is the first to work with Python 3.

When do you anticipate it will be added to PyPM?

Many thanks!

guthrie | Wed, 2013-06-12 19:31

I am trying to use pylab with Active Python 2.7, but cannot get it installed.

The closest library I could find is matplotlib, and some refrences say that them I can import: matplotlib.pylab, but but trying to install it fails:

C:\Users\python>pypm install matplotlib
The following packages will be installed into "%APPDATA%\Python" (2.7):
Hit: [] matplotlib 1.1.1
Installing matplotlib-1.1.1
error: cannot overwrite "%APPDATA%\Python\Python27\site-
packages\dateutil\" (and 590 other files); run pypm as "pypm
--force ..." to overwrite anyway; run "pypm log" to see the full list
of files to be overwritten

The AS-AP site ( ) says:
NumPy, SciPy and matplotlib are available for Windows, Linux and Mac OSX in ActivePython Community Edition.

Is this because I have the AS python & both installed? When I run the binary installer, it finds the version and path- "found in the registry", and does not allow me to change the install path, or choose a different version.

If I try pypm, I get the above.

guthrie | Sun, 2014-07-20 08:42

I'd love to get a solution to this!

"pypm install pylab" just says "no such package found".
(I have installed numpy, matplotlib & scipy.)