tbcload -is redirect error using tclapp.exe on Windows 7

Posted by asilver on 2012-11-09 13:12
Forums: TDK support | OS: Windows 7

I have a bunch of Windows .bat scripts that I use to build tclapps and they have been working fine for a while. I'm positive I did not change any of the build scripts at all but they are no longer working and I get the following error. Note the entire command line is not included below.

Again, this has been working for at least a year now.. This is using TCL Dev Kit 5.2

Thanks

Al Silverstein

tclapp.exe -compile -compilefor 8.5 -interpreter ./my_tkbase.exe -out myprogram.ngl ......

error package 'tbcload -is redirect' is not known (Specified, Not recoverable)
error
error Aborting
error

andreas.kupries
ActiveState Staff
Mon, 2012-11-19 12:58

Resolved in email communication.
Apparently a loss of the TAP/TEApot Package Search Paths (stored in the registry) causing TclApp to not find the package anymore.

oehhar | Tue, 2014-06-24 23:46

I have the same issue.

Would it be possible that the solution could be posted here ?

I have tried to reinstall ActiveTCL.
It is still the same.

IMHO the teapot works well.
Here is a snippet on Windows-32 bit cmd.exe session:

C:\Users\oehhar>teacup get tbcload 1.7 win32-ix86

Retrieving package tbcload 1.7 win32-ix86 ...@ http://teapot.activestate.com ...
 Ok

Output directory C:/Users/oehhar
1 package found, copying retrieved file ...

Copying package-tbcload-1.7-win32-ix86.zip

Thank you,
Harald