Local repository didn't work, remote repository did ?

Posted by jupiterferris on 2012-10-26 12:28
Forums: PPM | OS: Windows Server 2003

Hi all,

Could anyone explain the reasons behind what I had to do here ?

I know nothing about perl/tk, but I had to install a (Win Server 2003) application which needed Active Perl 5.12.x and Perl Tk, and they had to be installed manually. The application assumes internet access is available to get the Tk module, but it wasn't in this case.

After a rapid learning curve I downloaded Tk0804.030 from CPAN, created a PPD file for it and added a local repository in PPM. It saw the gz file OK and allowed me to add the package, but it didn't work as nothing was added under perl\site\lib when installation was finished... no error messages displayed on console though, and the module listed as added OK, I could remove/uninstall it OK.

Messing around with the ppd, trying Perl 5.10, Tk 0804.029,.028 didn't help. I tried it on a different PC with internet access and it worked OK when downloading Tk 804.029 from the web repository, but I got the same problem with the local repository and my ppd and gz.

Eventually I've had to 'grab' the module it downloaded from the web repository, ie get a copy of it before it deleted it after the installation process (have to be quick!), mod the downloaded ppd slightly to reflect the local file, then copy the ppd and gz onto the Win 2003 PC. That has all worked OK.. success.

I am wondering...

Why the PPM downloads TK 804.029 and not 804.030?
Why the 804.029 I can download manually is ~6.7MB, but the version downloaded automatically via PPM is ~1.75MB?
What I was doing wrong with the local repository, why did the installation show as OK but file to write to the site\lib dir?

The working PPD has a lot of "PROVIDE NAME" entries in which I didn't have.....but the gz file itself is different.

Thanks all.