I get error as "package require tdom"

Posted by cjingade on 2012-08-25 04:54
Forums: TEA discussions | OS: Linux

Hi I am new to TCL and I want to use parse XML files using tdom.

This is my script :

package require tdom
puts "Hi DOM"

And I get error like below :::

can't find package tdom
while executing
"package require tdom"

Do I need to install this tdom package explicity? If yes, can you please share the download path ?

gkubu | Sat, 2012-09-01 23:22

The installation contains some of the most popular packages only. You will get the rest from the teapot archive. For a complete update, execute

teacup update

in a tclsh. For more options and how to deal with a proxy etc. see the teacup documentation.