Serial port access under Perl 5.14 for 64bit?

Posted by a50mhzham on 2012-07-04 12:24

I've installed

C:\Perl64\my.programs>perl -v

This is perl 5, version 14, subversion 2 (v5.14.2) built for MSWin32-x64-multi-t
hread
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2011, Larry Wall

Binary build 1402 [295342] provided by ActiveState http://www.ActiveState.com
Built Oct  7 2011 15:19:36

I've been struggling with old scripts that need to talk to the serial port and I can't find any support for serial ports in either CPAN or PPM (not that CPAN actually works for me; that's yet another question.) I've been reading the FAQs and the Forum and have had no luck after more than a week.

I've tried Win32::SerialPort (can't find it) and Device::SerialPort (can't find it either).

I used Win32::SerialPort until changing to Win7 64. I use Device::SerialPort on Linux machines.

Is there ANY way to write to the serial ports under this version of Perl in a 64-bit env?

montana123 | Thu, 2012-09-06 15:02

ppm install http://www.bribes.org/perl/ppm64/Win32-API.ppd
ppm install http://www.bribes.org/perl/ppm64/Win32-SerialPort.ppd

replace ppm64 with ppm if using the 32 bit version of activestate perl ("perl -v" x64=64bit x86=32bit)

use bribes since the following shows that activestate doesn't support serialport on your version of activestate perl

http://code.activestate.com/ppm/Win32-SerialPort/

a50mhzham | Thu, 2012-09-06 20:36

Thanks so very much for this info. I've installed the two packages about without trouble and will test as soon as I have time to write some code.

I added bribes as another secondary repository so I don't have to specify it explicitly. Helpful instructions here, for the beginner:
http://www.bribes.org/perl/ppm64dir.html

Thanks again.

shell_l_d | Mon, 2013-01-28 20:42

My new pc has Windows 8 (64-bit) & am having the same problem, the only 64bit versions of ActivePerl avail to download are v5.14 & v5.16, yet neither have Win32::SerialPort.

I'm trying to find an ActivePerl Community Version for Windows 8 (64-bit) that has:
• HTTP::Request::Common
• LWP::UserAgent
• Win32::SerialPort (or Device::SerialPort for Unix/Linux users)

http://code.activestate.com/ppm/AnyEvent-HTTP-LWP-UserAgent/
- says v5.12, v5.14 & v5.16 all work.

http://code.activestate.com/ppm/Win32-SerialPort/
- says ONLY v5.12 works, not v5.14 or v5.16, yet v5.12 is not avail to download.

I tried the www.bribes.org links above but they don't work.

Any ideas please? :)

Thanks heaps