treectrl 2.4.1 / installing mixed packages from files with teacup

Posted by redted on 2012-05-21 09:29
Forums: ActiveTcl support | OS: Windows Linux

Hello,
I would like to use treectrl 2.4.1 (published 2011-10-17). Unfortunatly it is not in the default teacup repository (only 2.4). I tried installing it with teacup with

teacup install file://C:/unzipFolder/

which errors "can't overwrite someRandomTempFile", I tried deleting the temp file, however I keep getting the same error, even though the file did not exist before I started teacup install.

Since this does not work for me a valuable workarround would be to just put the folder with treectrl into my working directory, however if I try yhis I get the following under windows:

couldn't load library "Z:/files/tcl/encounterXtract/treectrl_win/treectrl24.dll": invalid argument
while executing
"load Z:/files/tcl/encounterXtract/treectrl_win/treectrl24.dll treectrl"
("package ifneeded treectrl 2.4.1" script)
invoked from within
"package require treectrl"

SO how do I install from the zip file/the unzipped directory or what do I have to do so that I can simply integrate the library into the working folder of my tcl project?
And if I do so, is there anything I need to do, besides putting the linux .so lib into the same directory (may not install libs in /usr/lib) to make it work under linux as well?

Greetings ted