Komodo IDE XDEBUG

Posted by rsvancara on 2012-02-12 19:20

Hi,

I am using Komodo IDE, version 7.0.0, build 68957, platform linux-x86_64. Built on Thu Jan 26 02:18:48 2012, and I am experiencing problems using remote xdebugging for a Drupal (PHP) site. In brief, I have installed xdebug (several times), I enable debugging in the browser by ?XDEBUG_SESSION_START=1 and nothing happens in komodo. Both komodo and xdebug are configured to use port 90001. Does anyone have any advice on what to try. Details are included below.

I have followed the following links to obtain understanding and clarity regarding the topic.

http://docs.activestate.com/komodo/6.0/trouble.html#php_debug
http://docs.activestate.com/komodo/4.4/debugphp.html
http://community.activestate.com/faq/how-do-i-get-php-remote-debugging-w...

I have a local instance of php-fpm installed, using the xdebug.so module. I have tried the module from:

http://code.activestate.com/komodo/remotedebugging/
http://xdebug.org/download.php

AND the provided xdebug package for Debian/Mint

I have configured my xdebug.ini like this:

zend_extension=/usr/lib/php5/20090626/xdebug_custom.so
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9001
;ddxdebug.profiler_output_name=xdebug.cachegrind-out.%s.%p
;xdebug.var_display_max_depth=10
;xdebug.remote_log=/var/log/php-fpm/xdedug.log

I have komodo configured to use the remote port of 9001.

Edit->preferences

And then

Debugger->Connection

A specific port, 9001 is selected.

According to Debug->Listener Status,

Debugger Listing: Yes
Host Address: BLANK
Host Port: 9001
...
Current Connections: 0
Total Connections: 38

It appears that everything is configured correctly, however, when I attempt to start the debugging session my appending ?XDEBUG_SESSION_START=1 to my URL, nothing happens. I even created a very simple page called phpinfo.php with two lines:

<?php

echo phpinfo();

I set the break point in echo phpinfo(); and nothing happens.

I have turned on logging in the debug.ini which is called by the php.ini. It looks like komodo is being sent information, but it is just not doing anything with it. Please see attached gzipped xml file.

AttachmentSize
xdedug.xml.gz19.32 KB

cgchoffman
ActiveState Staff
Mon, 2012-02-13 12:36

I am not able to reproduce this scenario. From the log file you sent it appears that your machine had slightly more success on port 9000. Have you tried using a system assigned port? Preferences->Debugging->Connection:"a system provided free port"

The listener status; Debug->Listener Status, will tell you which port Komodo is not using to listen for connections. Edit your php.ini file then restart Apache...I assume you're running Apache. Please correct me if I'm wrong.

Cheers,

-Carey

rsvancara | Mon, 2012-02-13 13:11

I will give your suggestions a try. This was one of the big reasons I purchased this over other projections was for the debugging integration.

Also, I am using PHP-FPM, which I will restart.

rsvancara | Mon, 2012-02-13 13:28

Ok, that worked.

rsvancara | Mon, 2012-02-13 13:28

Ok, that worked.

cgchoffman
ActiveState Staff
Mon, 2012-02-13 13:42

Which part worked?

Glad I could help!

-Carey

rsvancara | Mon, 2012-02-13 16:10

The part where you said to let Komodo select an empty port. I just set PHP Xdebug to use the matching port and it worked. So now I am wondering why things are not working on port 9000, but at one point, php-fpm was using this port.

cgchoffman
ActiveState Staff
Mon, 2012-02-13 16:44

Something else could have been using that port. Mine worked fine with 9000 and 9001 though. Your log indicated that you tried both. Maybe there was a mix up at some point and you didn't have them matching.

I'm glad you've got it working now.

-Carey