Komodo Edit 7

Posted by ronald on 2012-02-01 12:54

Hi,

I just installed Komodo Edit 7 on OS X 10.5.8 (Mac Mini). When I try "File/New/New File", Komodo Edit displays (in a gray box) "A plugin is needed to display this content".

I renamed version 7 to "Komodo Edit 7" and installed Komodo Edit version 6 (6.1.3, build 8844). This seems to work fine. (At least it creates and displays new files and opens exiting ones--I just reinstalled it to see if it would work.)

Anyone have a clue as to what is going on?

Best regards,

toddw
ActiveState Staff
Thu, 2012-02-02 12:35

That seems like a strange one - the only thing that comes to mind is that when installing Komodo Edit 7, it defaults to:
/Applications/Komodo Edit

and perhaps there was problem over-writing the older Komodo 6 version that used to reside there - or you may have had Komodo Edit 6 running when you did the Komodo Edit 7 installation - meaning some files couldn't be properly overwritten... just some guesses.

Cheers,
Todd

ronald | Thu, 2012-02-02 15:00

Thanks Todd.

I tried reinstalling Komodo Edit 7 but it continues to have the same problem. Initially, I had moved Komodo Edit 6 out of the Applications folder. Later I deleted it and reinstalled it. Do you or anyone else know if there are common files stored elsewhere that I might have to remove?

Thanks in advance for your help.

Best regards,

Ron

toddw
ActiveState Staff
Thu, 2012-02-02 15:29

You could try resetting the Komodo profile to see how that goes:
http://community.activestate.com/faq/komodo-file-locations#pref_reset

Also - anything interesting in the Komodo error log "Help > Troubleshooting > View log file"?

chris3 | Mon, 2012-02-06 03:43

Hi Todd,

I have exactly the same problem. There was no previous version of Komodo Edit installed on my Mac (version 10.5.8), and resetting the Komodo profile didn't help. When I want to have a look at the log files, I get the same "plugin is needed" error and no files are shown.

Best regards,
Chris

cgchoffman
ActiveState Staff
Fri, 2012-02-10 11:34

Did you try to open the log file with Komodo? If you did, could you try and open it with something else?

Cheers,

-Carey

chris3 | Mon, 2012-02-13 07:56

The problem seems somehow to be connected to a plugin termed SciMoz.
The error log shows many entries, that look like this:

-- EXCEPTION START --
+ fileName (string) 'file:///Applications/Komodo%20Edit%207.app/Contents/MacOS/components/scimoz_wrapper.js'
+ lineNumber (number) 1329
*
koSciMozWrapper_init([object HTMLEmbedElement],[object XULElement])@file:///Applications/Komodo%20Edit%207.app/Contents/MacOS/components/scimoz_wrapper.js:1329
get_scimoz()@chrome://komodo/content/bindings/scintilla.xml:160

The console log shows the following entry concerning Komodo:

Error loading /Komodo Edit7.app/Contents/MacOS/plugins/SciMoz.plugin/Contents/MacOS/SciMoz: dlopen(/Komodo Edit7.app/Contents/MacOS/plugins/SciMoz.plugin/Contents/MacOS/SciMoz, 262): no suitable image found: Did find:
/Komodo Edit7.app/Contents/MacOS/plugins/SciMoz.plugin/Contents/MacOS/SciMoz: unknown required load command 0x80000022

Chris

mook_as
ActiveState Staff
Mon, 2012-02-13 11:51

Thanks! That last line was probably the problem - it looks like we built the Mac binary wrong :( Does this help? We probably need to figure out what went wrong there, or build everything on a 10.5 machine (which I thought we did, but I might be mistaken).

chris3 | Thu, 2012-02-16 03:47

No, unfortunately the workaround didn't help, I get the same error message. But Komodo 6 also works very nicely ;)

sameerel | Thu, 2012-02-09 22:47

Hi guys,

I'm facing the same problem as mentioned by Ronald, Please can someone provide the steps to fix this, I want to install komodo edit on my Mac.

cmorsino@gmail.com | Tue, 2012-02-21 20:41

I am trying to understand the language you are speaking to fix the problem, but I am very new to this. The easiest advice I saw was to delete version 7 and download version 6, but I can't find Version 6 on the Activestate website. Please help!

Thank you!

feluce | Mon, 2012-02-13 06:46

Hi,

I am using Mac OS X 10.5.8, I never ever used Komodo Edit before and I've the same problem.... It seems to be a kind of bug. Isn't there a bugfix out there? Is someone doing something about it? That would be very nice...

Best wishes...

msbranin | Sat, 2012-02-18 14:07

Still No word on getting Komodo Edit 7 to work with OSX 10.5.8??

sameerel | Sun, 2012-02-19 22:26

I switched over to use komodo 6 on my Mac and it works,

Komodo team please fix this bug soon would really like to use komodo 7 :(

mook_as
ActiveState Staff
Mon, 2012-02-20 10:32

Sorry about that - this is being tracked as bug 92814. Any nightlies after Feb. 16 would start (except that seems to be missing for some reason, more things to figure out...), but will be broken with some things like running HTML tidy. I'm currently looking into it.

Sorry about this, guys - we didn't have enough testing and missed trying to start things on 10.5 :( Wrong linker flags, yay.

cgchoffman
ActiveState Staff
Wed, 2012-02-22 10:20

Again sorry about this folks, Mook is working as fast as he can on this and we have a release dropping soon that the fix will be in.

Someone above asked where you could get Komodo Edit 6 :

- Komodo Edit 6.1.3

If you can, reply to this thread on a post above so as not to bury this post. We'll bury it with a fixed release soon :D

Thanks for your patience,

-Carey

cmorsino@gmail.com | Wed, 2012-02-22 11:41

It works!

berni | Thu, 2012-02-23 11:56

Thank you for the link. This version works!

d_l | Thu, 2012-03-29 09:03

I've got Komodo Edit, version 7.0.2, build 9923, platform linux-x86. Built on Thu Mar 15

When trying to preview a flash object in Komodo tab window I'm seeing the message ..

"a plugin is needed to display this content"

but flash object can be viewed o.k. in external browser.

how do I install the Adobe flash plugin in Komodo for internal preview of flash objects?

===================================================

[Edit] I found another thread which refers to flash plugin

http://community.activestate.com/forum/swf-komodo-browser-preview

In ubuntu terminal I ran the command .. locate libflashplayer.so

copied libflashplayer.so into ../Komodo-Edit7/lib/mozilla/plugins/

there was only one file in that folder ..

libnpscimoz.so (I'm not sure what that plugin does ?)

I restarted Komodo and I could then preview flash content.

[SOLVED]