Teapot? What Teapot?

Posted by robert_thrift on 2011-09-22 17:14
Forums: TEA discussions | OS: Windows Vista

I downloaded and installed ActiveTcl 8.5.10, Community Edition, today.
It was installed on a Windows Vista PC with no problems or error messages.
I tried it out on a couple of Tk programs I had written long ago, and they worked.

I became interested in a statement on the web page
because it discussed the "teapot" program/script/facility, whatever it is.
That's new to me; I think my old ActiveTcl was 8.4 or thereabouts.

Here is what the web page says:
"Download ActiveTcl Community Edition to get started, then launch Teapot which provides
both command line and user interface access to all modules available through Teapot."

Well, there is no teapot of any kind that got installed, although as far as I can tell,
everything else is there, including a copy of teacup.exe. Which I guess I can't invoke
alone by itself.

So where is teapot? I did a Windows search on the entire hard disk (about a 2-hour job)
and turned up nothing.

Does ActiveTcl 8.5.10 install teapot, or not? If not, how do I get it?

Just as an aside, what does "launch Teapot" actually mean in the ActiveTcl world? Do I
click on it in Windows? Invoke it from tclsh? Or what? (If I even had teapot, I mean.)


robert_thrift | Tue, 2011-09-27 13:45

I never figured out the teapot mystery, but I solved the problem in a different way. I downloaded and installed the ActiveTcl 8.6 beta version, and teapot was there and working. There was a teapot.exe compiled for Windows and I could run it by command line from the DOS window, which works OK.

The teapot documentation that comes with ActiveTcl is certainly no substitute for a tutorial, but with enough head-scratching and jumping back and forth between the man pages, it is at least possible for a newbie to get some use out of it.


ActiveState Staff
Fri, 2011-11-18 10:24

> then launch Teapot

The text on the web page is wrong. At least misleading. Let me try to clarify things here first. I will then work with our web people to fix the web page as well.

TEApot is what we call our repository of prebuilt packages (binary and pure Tcl), found at http://teapot.activestate.com/

The client application to access this repository (and compatibles) is called "teacup(.exe)". As Robert said, this client comes with the ActiveTcl distribution. In fact, all distributions, 8.4 and up, released in the last 2 years at least should contain this client.

This client is a command line application, to be run from a terminal (DOS box, on Windows). Its syntax is described in the HTML/CHM help of ActiveTcl, and can also be accessed from the command line itself, through 'teacup help'.

The packages installed via this client land in a directory /lib/teapot, which is an 'installation teapot repository' (*), and our tclsh and wish are configured at installation time to search it for packages.

I hope this clarifies things. If not, just ask.

(*) This and other terms are explained in the 'TEApot glossary' in the HTML documentation.

cp99 | Sun, 2018-02-04 10:28

So... 7 years later, the site still says: "Download ActiveTcl Community Edition to get started, then launch Teapot"

You still claim 'Expect for Windows' all over your site. What a rubbish site!

hotcore | Mon, 2017-04-17 03:49

> The client application to access this repository (and compatibles) is called "teacup(.exe)". As Robert
> said, this client comes with the ActiveTcl distribution. In fact, all distributions, 8.4 and up,
> released in the last 2 years at least should contain this client.

In fact in version 8.6.6. there is no teacup.exe anymore.

Where can I download the teacup related stuff as stand-alone package?


ActiveState Staff
Thu, 2017-04-20 07:53

Teacup has been dropped from 8.6.6. It never was a package, so there's no way to download it separately. Important portions of the TEA ecosystem were only available in the TDK, which has also been discontinued.

To add modules in 8.6.6 you need to add them the way the authors intended them to be added.

The TEA system may get opensourced, and if TEA or something based on it, gets adopted as a community standard package system for Tcl (9.0?), it will return.

jeffr@activesta... | Thu, 2017-06-15 14:12

Hi Everyone,

We’ve had some inquiries of late about Tcl Dev Kit (“TDK”) and Teapot/Teacup so I wanted to give everyone an update on our plans.

Over the last six months we’ve released ActiveTcl 8.6.6 on Windows, MacOS, and Linux. We’ve also included Tcl 8.6 updates in our Komodo IDE. We are continuing to work on 32 bit versions of ActiveTcl 8.6.6 and on revamping our code intelligence with Tcl inside of Komodo, which will be available in the Fall.

As I mentioned in a recent blog post we are planning to open source Teapot and Teacup. This will be done with a BSD 3-clause license into a public Github repository. We’ve been talking to members of the Tcl community who may help us facilitate this, and we are looking forward to continuing to provide the hosting services for Teapot to continue to serve packages for the community (as well at the Tcl.tk site). We’ll also make an announcement when this is completed, date TBD. However, if there is a particular way you would like to see Teapot and Teacup open sourced and/or hosted, don’t hesitate to provide feedback to me directly or to the mail list where we can discuss the best way for this to happen. Your feedback will assist us in successful planning and execution.

For TDK, we are still supporting it for existing TDK customers. Currently our support of TDK is up to Tcl (8.6.6 and higher will not support the TDK). We discontinued selling it as a standalone developer tool product in February, but we continue to sell it as part of ActiveTcl Enterprise or OEM.

As always, don’t be shy to reach out with questions.



dirkmudge | Tue, 2017-10-24 07:07

I just installed ActiveTCL 8.6.6 but when trying to spawn plink I receive the message invalid command "spawn" Please help I am stuck and really need to get this working..

ActiveState Staff
Mon, 2017-10-30 08:04

It's not directly related to the thread above it.

You need Linux or OS X.

On Windows, Expect is not an included module with any ActiveTcl since 8.4, and 8.6.6 can't use TEApot, so you can't install Expect.

Use Linux or OS X. 8.6.6 includes Expect if you're on a platform where Expect works.

cp99 | Sun, 2018-02-04 10:30

Brilliant! Just wasted a few hours of my time on this 'cos you can't be bothered to update your site.

Really unprofessional, I shan't be going to AS anymore for help.

orselcem@yahoo.com | Wed, 2018-03-07 00:51

My sentiments exactly. Please don't promise Expect for Windows unless you intend to deliver it.

skycam37 | Mon, 2017-11-20 07:09

I just got Tcl 8.6 for Linux and was dismayed to find that teacup is missing. I have a number of tcl/tk programs that need iwidgets and widget. How do I get these now?

ActiveState Staff
Tue, 2017-11-21 16:19

The new 8.6 installers are "fat" installers; like the old 8.4 installers used to be.

The 8607 installer includes iwidgets 4.1 and bwidget 1.9.10 pre-installed.