Problem with PPM - unable update installed package?

Posted by grivel on 2011-08-27 10:02
Forums: PPM | OS: Other Linux

Hello,

I have mistake with ppm, I use "(v5.14.1) built for i686-linux-thread-multi - ActiveState and PPM V4.13 for Perl 5.14.1.1401"

Problem:

I try update de package, my first feeling is good, but i do not understand why PPM install new version about pkg and keep old pkg, for me is not a update system, I read the manual before writing this.

I try in preferences unlock the PERL area, I didn't do this? I try sudo, no change. When I quit the gui PPM on my terminal have this text, maybe have probleme?

Text:

X Error of failed request: RenderBadPicture (invalid Picture parameter)
Major opcode of failed request: 149 (RENDER)
Minor opcode of failed request: 7 (RenderFreePicture)
Picture id in failed request: 0x20
Serial number of failed request: 7989
Current serial number in output stream: 8021

Thank's for the crew and answer :-)) alex

grahams
ActiveState Staff
Mon, 2011-11-21 17:01

PPM only manages the "site" area.

"Site" is modules which you have added yourself.

PPM cannot remove anything installed under the "perl" area. These are core modules and modules shipped with ActivePerl. ActivePerl is configured so that anything installed under "site" will have precedence over anything with the same name installed under "perl".

That error message can be ignored.