TCL 8.5.9.2 & Teacup Issue

Posted by craig_pace on 2011-06-21 03:52
Forums: TEA discussions | OS: Windows 7

Hi,
I've just unstalled TCL 8.5.9.2 for Windows, and am trying to update to the latest versions of Expect using teacup.
I've set the timeout to 120s, but for some reason, I can't update/connect. The following us seen:

% teacup version

8.5.9.2.294317

% teacup list teacup
0 entities found

Problems which occurred during the operation:
* http://teapot.activestate.com :
timeout

% teacup timeout 120
Timeout set to 120 seconds
% teacup list teacup
0 entities found

Problems which occurred during the operation:
* http://teapot.activestate.com :
HTTP INTERNAL ERROR: connect failed connection timed out HTTP
INTERNAL ERROR: while executing HTTP INTERNAL ERROR:
"http::geturl
http://teapot.activestate.com/entity/name/teacup/list -binary 0
-command {::snit::RT.CallInstance
::repository::proxy::Snit_inst2 Receive..." HTTP INTERNAL ERROR:
("eval" body line 1) HTTP INTERNAL ERROR: invoked from within
HTTP INTERNAL ERROR: "# Compiled -- no source code available
HTTP INTERNAL ERROR: error "called a copy of a compiled script""

Any ideas? it is a network issue? or maybe avast?

andreas.kupries
ActiveState Staff
Tue, 2011-06-21 10:03

Hi Craig

I just (11am PDT) tried to access the teapot from my personal linux machine (which is outside of AS' network), and had no issue at all.

I suspect that you encountered some transient network problem.
Can you please try again to make sure ?

Note: A timeout of -1 means infinity, i.e. no timing out.
Note 2: The option '-v' will make the operation a bit more verbose, i.e tell you which requests are currently made.

craig_pace | Tue, 2011-06-21 23:37

Hi,
Yeah, I suspect a network problem somewhere.
WHen I do the same from my Windows 7 PC at home, there is no problems.

Using verbose mode from work I see:

% teacup update-self -v
Updating C:/tcl/bin/teacup.EXE ...
http://teapot.activestate.com: Retrieving remote INDEX status ...
http://teapot.activestate.com: Got Status Failed
http://teapot.activestate.com: Got Status = 0 (HTTP INTERNAL ERROR: connect failed connection timed out
HTTP INTERNAL ERROR: while executing
HTTP INTERNAL ERROR: "http::geturl http://teapot.activestate.com/db/status -binary 0 -command {::snit::RT.CallInstance :
:repository::proxy::Snit_inst2 Receive {command {::s..."
HTTP INTERNAL ERROR: ("eval" body line 1)
HTTP INTERNAL ERROR: invoked from within
HTTP INTERNAL ERROR: "# Compiled -- no source code available
HTTP INTERNAL ERROR: error "called a copy of a compiled script"")
http://teapot.activestate.com: Disabled local processing. No status
Not found in the archive.

Problems which occurred during the operation:
* http://teapot.activestate.com :
HTTP INTERNAL ERROR: connect failed connection timed out HTTP
INTERNAL ERROR: while executing HTTP INTERNAL ERROR:
"http::geturl
http://teapot.activestate.com/find/all/teacup%20%2dis%20application%20%2...
%7d/win32%2dix86%20tcl
-b..." HTTP INTERNAL ERROR: ("eval" body line 1) HTTP INTERNAL
ERROR: invoked from within HTTP INTERNAL ERROR: "# Compiled --
no source code available HTTP INTERNAL ERROR: error "called a
copy of a compiled script""

Any ideas what could be causing the error? Virus S/w?

andreas.kupries
ActiveState Staff
Wed, 2011-06-22 06:22

Given the difference between at work vs at home, might it be that your system admins at work require you to go through a proxy server to access the web ?

Can you access http://teapot.activestate.com/db/status from a plain browser ?
If yes, what proxy settings does the browser use ?

craig_pace | Wed, 2011-06-22 12:06

Hi,
I enabled the Proxy with Teacup, using the same settings as the Web Browser.
This has resolved the issue

teacup proxy "proxyserver.xxx.xxx" 8080

Thanks again.

Craig

andreas.kupries
ActiveState Staff
Wed, 2011-06-22 12:59

Glad to hear that. You are welcome.