Iwidgets and activetcl 8.6

Posted by agstcl on 2011-05-04 06:24

I installed ActiveTcl 8.6 on a 64bit fedora 14.
I tried package require Iwidgets and nothing happen. Then I read same pages and run
./teacup install --with-recommends Iwidgets

and then every time i exec package require Iwidgets I obtain

segmentation fault .......

andreas.kupries
ActiveState Staff
Mon, 2011-05-09 09:05

Hi agstcl.

Iwidgets requires itk, and itcl.
For Tcl 8.6 the proper Itcl is v4.
However, AFAIK, the itk v4 is not yet operational, making iwidgets impossible to use with 8.6.

The segmentation fault you see may mean that your system is trying to use itcl/itk 3.x instead which will not work for 8.6.

Right now using iwidgets requires use of Tcl 8.5, plus itcl/itk 3.x.