Upgrading to libwww-perl ver. 6.02 failed

Posted by meir on 2011-04-09 08:19
Forums: PPM | OS: Windows XP Pro

Hi all!

I posted the following on the libwww-perl mailing list but nobody took a bite!

I tried to upgrade the libwww-perl from 5.837 to 6.02. This is with ActivePerl 5.10.1.1006 using PPM v.4.06.

This caused 12 dependent packages to be attached to the libwww-perl one:
LWP-MediaTypes
Encode-Locale
HTTP-Message
File-Listing
HTTP-Negotiate
HTTP-Daemon
Net-HTTP
HTTP-Cookies
HTTP-Date
WWW-RobotRules
IO-Compress
Compress-Raw-Bzip2

All the "Downloading ...", "Unpacking ..." and "Generating HTML for ..." stages were "done". So far so good!

Then "Updating files in site area ... failed" with the following message:
"Error: The package IO-Compress-Zlib has already installed a file that package IO-Compress wants to install."

Well, what should I *DO*???

meir

grahams
ActiveState Staff
Mon, 2011-04-11 11:23

Use the --force option to make it proceed over objections like this.