Moose on 5.10 ppm build system

Posted by lespea on 2011-03-29 07:09
Forums: PPM | OS: All / Any

Would it be possible to fix Moose on the ppm build system. None of my Dist::Zilla modules will build correctly because of how broken it is. One small example:

Package::DeprecationManager version 0.07 required--this is only version 0.04 at C:/cpanfly/var/megalib/Moose/Deprecated.pm line 22.
BEGIN failed--compilation aborted at C:/cpanfly/var/megalib/Moose/Deprecated.pm line 22.

On my personal dzil bundle I try to manually "fix" the issues but then it won't compile because the build takes too long to update everything.

I'm not the only author who is experiencing these issues.