Can't install some modules on win server 2008 x64

Posted by pernilla on 2011-03-29 04:18
Forums: PPM | OS: Windows x64

I can't install the following modules:

Encode-JIS2K
XML-libXML-common
SGML-Parser-OpenSP
Encode-HanExtra

I have them but they don't even show up as an option to install. They don't show up if I add the direct path to them in the PPM site either.

I use the ActivePerl-5.10.1.1008-MSWin32-x86-294165.msi build on win server 2008.

Any idea how I can solve this issue? I can't use other modules as they are need for a specific script to work.

grahams
ActiveState Staff
Wed, 2011-04-06 11:16

What exactly do you have?
If you have source code files, then you can't install them with PPM. You should be using the "cpan" script instead.

If you have ppd or ppmx files (and for build 1008 you should have PPMX files), then you're looking at files which are compatible with PPM. They won't show up in the PPM browser unless you set up the structure for a local repository and point the PPM client at it. All you need to do with ppmx files is tell PPM to install them:
http://docs.activestate.com/activeperl/5.12/faq/ActivePerl-faq2.html#ppm...