DBD-mysql Problem

Posted by howardparsons on 2018-03-06 15:32

Hi!
This is a 'shot-in-the-dark' question but I'm at a loss otherwise.

I've been developing a Perl script that connects to a MySQL DB. For the past couple of days, everything has been swell. This morning, I ran another test and when I tried to connect to my DB, I got a message in Komodo saying 'No such file or directory'.

Since I don't believe in malicious fairies or gremlins, I must have accidentally deleted or changed something in the past 24 hours. I've tried reinstalling the package, etc. but nothing seems to work.

Would anyone one have any idea where that message is being thrown and what the root cause might be?

Thanks in advance.

Howard Parsons

grahams
ActiveState Staff
Wed, 2018-03-07 13:58

Perl will report the line number and the file of an error of this sort.

If you don't see the full message in Komodo, try running the script from the command line.

wuerger | Sat, 2018-04-14 20:00

Did you try

use Modern::Perl;
use diagnostics;

?