PPM installation does not initiate for String-CRC32 package

Posted by ngujarathi on 2018-02-01 07:32
Forums: PPM | OS: Windows 10


perl version 5.8.3

I set the http proxy from command line,

set http_proxy=http://UserName:Pwd@

and then trying to install String-CRC32 using,

ppm install String-CRC32

it gives below error,

C:\WINDOWS\system32>ppm install String-CRC32
Error: No valid repositories:
Error: 404 Not Found
Error: 404 Not Found

Can I get some help with it or a perl script for CRC32 calculation!!


ActiveState Staff
Thu, 2018-02-01 10:11

There are no compatible repositories.

ActivePerl 5.8.3 has been End-of-Life since 2004. The PPM version 3 servers were decommissioned in 2010.

Start by replacing your Perl.

ngujarathi | Fri, 2018-02-02 00:14

Thank you for the reply.

It worked with v5.18.2 but didnt work with 5.24

ActiveState Staff
Mon, 2018-02-05 13:12

When you're changing across major version numbers, make sure you manually remove anything that the uninstaller can't remove before you install the newer version.