can't install GnuPG::Interface

Posted by jack238 on 2017-10-30 13:38

Hello
When I try to do this : cpan install GnuPG::Interface
either on Strawberry or Activeperl ( windows ) I get this error :
(I tried 32 bit version too )

CPAN: File::Temp loaded ok (v0.2304)
CPAN: YAML::XS loaded ok (v0.66)
CPAN: CPAN::Meta::Requirements loaded ok (v2.140)
CPAN: Parse::CPAN::Meta loaded ok (v2.150010)
CPAN: CPAN::Meta loaded ok (v2.150010)
CPAN: Module::CoreList loaded ok (v5.20170821)
Configuring A/AL/ALEXMV/GnuPG-Interface-0.52.tar.gz with Makefile.PL
which gpg ... 'which' is not recognized as an internal or external command,
operable program or batch file.
gpg (GnuPG) not found at Makefile.PL line 7.
Warning: No success on command[C:\Perl64\bin\perl.exe Makefile.PL INSTALLDIRS=si
te]
  ALEXMV/GnuPG-Interface-0.52.tar.gz
  C:\Perl64\bin\perl.exe Makefile.PL INSTALLDIRS=site -- NOT OK

Any tip ? Im actually trying to install Mail::GnuPG but GnuPG::Interface is required.
thank you

grahams
ActiveState Staff
Fri, 2017-11-10 13:10

http://cpansearch.perl.org/src/ALEXMV/GnuPG-Interface-0.52/Makefile.PL
The makefile tries to locate GnuPG using the Unix/Linux "which" command. Windows does not have a "which" command. Since the makefile has no alternative logic that Windows can use, you have to assume no support for Windows.