Is GLIBC_2.14 a minimum requirement? - Would GLIBC_2.17 be supported then?

Posted by cmh2890 on 2017-09-27 08:07

I am having a similar issue to nissam in post 12912 where they are having difficulty installing ActivePerl due to the requirement for GLIBC_2.14.

We are only able to install either GLIBC_2.12 or GLIBC_2.17 (available in the next RH release).

Would ActivePerl 5.2x support this GLIBC_2.17 (i.e. a minimum requirement for GLIBC_2.14 or is GLIBC_2.14 a specific requirement)?

We won't be moving to Ubuntu or other distros as suggested in the previous staff post.

Thanks!

grahams
ActiveState Staff
Thu, 2017-09-28 09:42

2.14 is the minimum. GNU tries very hard to ensure that dependencies on older version of the glibc will be forward compatible.