Looking for 64bit version of tbcload1.7 for Linux

Posted by flyer_55 on 2017-09-14 13:50

I have been using the tbc compiler with ActiveState TclDevKit 5.4 on a 32 bit system and this has been working well. I can use the loader tbcload1.7.so and it loads the bytecode fine. I am migrating my development to a 64bit system and it will not allow me to use the tbc loader I have been using and gives me the error "wrong ELF class" which usually denotes using 32bit code on 64bit system.

I installed the DevKit for x86_64 however I cannot find a compiled version of the loader. Please advise if this loader is still distributed with the x86_64 version. If so, where is it located.